背景:
使用的环境中安装docker环境,但随着长时间的使用,系统根目录打满,导致容器服务失败,影响部署的服务;
问题描述
docker安装的服务,用户方反馈页面请求失败,部分页面返回500;最后问题反馈到我这边,登录页面的后端服务部署的机器,发现是docker安装的容器服务,使用docker ps,发现后端服务状态一直在重启,进一步分析发现是安装docker服务的机器根目录打满了,从而导致docker容器状态异常;
原因分析:
原因主要在3个方面:
一、 服务器的docker安装为默认安装,导致docker的目录保存在根目录下,而我们系统安装时,系统默认给根目录为50G;
二、 容器部署的后端服务在之后的迭代中,镜像文件不断的新增导致镜像目录不断增大;
三、 docker本身的服务日志和容器的日志也保存在根目录,同时日志文件没有做回收清理;
解决方案:
发现问题原因后,那就要实时的解决方法;
一、 根目录容量问题,这个设计到系统的重装,暂不考虑;
二.、docker overlay2磁盘解决方案;
1、分析docker磁盘占用情况,进入容器部署服务器操作如下:
a>. 使用docker info 命令查找docker安装路径:

本文主要介绍了由于Docker安装在根目录导致的空间不足问题,以及由此引发的容器服务异常。分析了镜像文件增加和日志未清理是主要原因。提供了解决方案,包括使用docker system prune清理磁盘,定时清理容器日志,以及通过修改daemon.json限制日志大小。

1551

被折叠的 条评论
为什么被折叠?



