Ubuntu 安装MySQL8 解决配置lower_case_table_names=1后启动失败

目录

一、问题描述

二、原因分析

三、解决方法


========  相关文章  ========

手搓一个人脸登陆、注册、手机扫码登陆

vue2开发环境和生产环境开启https

人脸登陆——Vue2 调用浏览器摄像头拍照及图片上传组件

【已解决】Could not build wheels for dlib, which is required to install pyproject.toml-based projects

一、问题描述

同命令sudo apt-get install mysql-server安装后,检查mysql服务状态为:running。

修改/etc/mysql/mysql.conf.d/mysqld.cnf文件,新增和修改内容如下:

bind-address = 0.0.0.0
lower_case_table_names=1
character_set_server=utf8

重启服务,启动报错,无法启动。

二、原因分析

mysql 8版本在安装完成后会立即启动,并完成数据库初始化,而且不再支持从mysqld.cnf文件中修改lower_case_table_names等参数。

三、解决方法

不必重新按装,但需要重新初始化数据库,过程如下:
1、删除数据后,确认正确配置lower_case_table_names

sudo rm -rf /var/lib/mysql
vim /etc/mysql/mysql.conf.d/mysqld.cnf
bind-address = 0.0.0.0
lower_case_table_names=1
character_set_server=utf8

2、手动初始化

mkdir /var/lib/mysql
chown mysql:mysql /var/lib/mysql
mysqld --initialize --user=mysql --lower-case-table-names=1

3、启动后获取root密码并登陆验证并修改密码

service mysql start
grep password /var/log/mysql/error.log

4、使用以上密码登陆并修改root密码:

mysql -uroot -p
ALTER USER 'root'@'localhost' IDENTIFIED with mysql_native_password BY '123456';
create USER 'root'@'%' IDENTIFIED with mysql_native_password BY '123456';
grant all on *.* to  'root'@'%';
flush privileges;

5、重启后登陆验证:

show variables like '%character%';
show variables like '%lower_case%';


6、完全卸载 mysql

systemctl stop mysql
sudo apt remove --purge mysql-* -y
sudo apt autoremove -y
sudo rm -rf /etc/mysql
sudo rm -rf /var/lib/mysql
sudo rm -rf /var/log/mysql

评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值