ORA-08102: index key not found

开发者福利!热门AI工具限时免费用 购周边即赠Coding Plan Lite,Claude Code、Cursor等20+工具畅享,效率翻倍! 阅读详情

创建索引时出现这问题:

SQL> alter table t add primary key(id);
alter table t add primary key(id)
*
ERROR at line 1:
ORA-00604: error occurred at recursive SQL level 1
ORA-08102: index key not found, obj# 52, file 1, block 77798 (2)

官方解释:

[oracle@centos6 ~]$ oerr ora 08102
08102, 00000, "index key not found, obj# %s, file %s, block %s (%s)"
// *Cause:  Internal error: possible inconsistency in index
// *Action:  Send trace file to your customer support representative, along
//           with information on reproducing the error

MOS(ID 1088018.1)上对ORA-08102错误的定义为:

An ORA-08102 indicates that there is a mismatch between the key(s) stored in the index and the values stored in the table.Wh
at typically happens in the index is built and at some future time,some type of corruption occurs,either in the table or index,to cause the mismatch.

ORA-08102常见于索引键值与表上存的值不一致。

产生原因:

a. Oracle bug

b. Block corruption in the index or in the table

c. Hard ware /IO

d. Function-based indexes(FBI)

接下来记录下对此错误的分析过程

1. 查看产生的trace文件

[oracle@centos6 trace]$ pwd
/u01/app/oracle/diag/rdbms/orcl/orcl/trace
[oracle@centos6 trace]$ cat alert_orcl.log
Sat Nov 19 12:06:36 2016
Errors in file /u01/app/oracle/diag/rdbms/orcl/orcl/trace/orcl_ora_3576.trc:
[oracle@centos6 trace]$ vim /u01/app/oracle/diag/rdbms/orcl/orcl/trace/orcl_ora_3576.trc
trace文件内容分析:

oer 8102.2 - obj# 52, rdba: 0x00412fe6(afn 1, blk# 77798)
kdk key 8102.2:
  ncol: 1, len: 5
  key: (5):  04 c3 02 10 5a
  mask: (4096):
 81 00 00 00 00 60 61 1a 8e 00 00 00 00 00 00 00 00 00 00 00 00 e0 c9 0c 0c
obj# 52:发生错误的对象为52号对象

rdba: 0x00412fe6(afn 1, blk# 77798):对象的rba为1号文件,77798号块

ncol:1 :一共有一个列

len:5 :列的长度为5个字节

key:(5) :列的key值为04 c3 02 10 5a,其中04代表行的长度,后面则是列的内容

从列的内容 c3 02 10 5a入手,利用oracle提供的函数将16进制转换为10进制:

SQL> select utl_raw.cast_to_number('c302105a') from dual;

UTL_RAW.CAST_TO_NUMBER('C302105A')
----------------------------------
                             11589
再回看发生错误的信息:

ERROR at line 1:
ORA-00604: error occurred at recursive SQL level 1
ORA-08102: index key not found, obj# 52, file 1, block 77798 (2)

oracle在调用递归sql的时候没找到索引键值,因为oracle在创建索引的时候需要找索引键。

2. 产生错误的52#对象

52#对象存在于bootstrap$里面,通过bootstra$找出52号对象

SQL> select * from bootstrap$ where obj#=52;

     LINE#       OBJ#
---------- ----------
SQL_TEXT
--------------------------------------------------------------------------------
        52         52
CREATE UNIQUE INDEX I_CON2 ON CON$(CON#) PCTFREE 10 INITRANS 2 MAXTRANS 255 STOR
AGE (  INITIAL 64K NEXT 1024K MINEXTENTS 1 MAXEXTENTS 2147483645 PCTINCREASE 0 O
BJNO 52 EXTENTS (FILE 1 BLOCK 464))
可以看到52#对象是一个建在Oracle内部表CON$上CON#列上的一个索引。

而且对于52#对象这样的bootstrap$核心对象是无法通过event 38003或migrate模式来重建的。只能使用bbed来修复。

3. 查看CON$

SQL> select user_id,username from dba_users;

   USER_ID USERNAME
---------- ------------------------------
        92 ORACX
        91 APP_SMARTPT_DB
        94 TEST
查出发生错误的用户编号,为94。

SQL> select name,con# from con$ where name='_NEXT_CONSTRAINT';

NAME                                 CON#
------------------------------ ----------
_NEXT_CONSTRAINT                    11589

CON$中,对应着_NEXT_CONSTRAINT,创建索引的时候,要到CON$找出最大的索引键值,即存放在NEXT_CONSTRAINT的这个值11589,也就是再找出这个最大的值时发生了错误。

4. 通过执行计划查看找出11589这个值的过程

使用全表扫描:找出的值为11589

SQL> set autot on
SQL> select  /*+ FULL(t1) */ owner#,name,con# from con$ t1 WHERE NAME='_NEXT_CONSTRAINT';

    OWNER# NAME                                 CON#
---------- ------------------------------ ----------
         0 _NEXT_CONSTRAINT                    11589


Execution Plan
----------------------------------------------------------
Plan hash value: 3767504726

--------------------------------------------------------------------------
| Id  | Operation         | Name | Rows  | Bytes | Cost (%CPU)| Time     |
--------------------------------------------------------------------------
|   0 | SELECT STATEMENT  |      |     1 |    24 |    14   (0)| 00:00:01 |
|*  1 |  TABLE ACCESS FULL| CON$ |     1 |    24 |    14   (0)| 00:00:01 |
--------------------------------------------------------------------------

Predicate Information (identified by operation id):
---------------------------------------------------

   1 - filter("NAME"='_NEXT_CONSTRAINT')


Statistics
----------------------------------------------------------
          1  recursive calls
          0  db block gets
         50  consistent gets
          0  physical reads
          0  redo size
        677  bytes sent via SQL*Net to client
        523  bytes received via SQL*Net from client
          2  SQL*Net roundtrips to/from client
          0  sorts (memory)
          0  sorts (disk)
          1  rows processed
使用索引:找到的值为11590

SQL> select  /*+ index(t1 I_CON2) */ owner#,name,con# from con$ t1 WHERE NAME='_NEXT_CONSTRAINT';

    OWNER# NAME                                 CON#
---------- ------------------------------ ----------
         0 _NEXT_CONSTRAINT                    11590


Execution Plan
----------------------------------------------------------
Plan hash value: 1812212496

--------------------------------------------------------------------------------
------

| Id  | Operation                   | Name   | Rows  | Bytes | Cost (%CPU)| Time
     |

--------------------------------------------------------------------------------
------

|   0 | SELECT STATEMENT            |        |     1 |    24 |    69   (0)| 00:0
0:01 |

|*  1 |  TABLE ACCESS BY INDEX ROWID| CON$   |     1 |    24 |    69   (0)| 00:0
0:01 |

|   2 |   INDEX FULL SCAN           | I_CON2 | 11211 |       |    22   (0)| 00:0
0:01 |

--------------------------------------------------------------------------------
------


Predicate Information (identified by operation id):
---------------------------------------------------

   1 - filter("NAME"='_NEXT_CONSTRAINT')


Statistics
----------------------------------------------------------
          1  recursive calls
          0  db block gets
         69  consistent gets
          0  physical reads
          0  redo size
        677  bytes sent via SQL*Net to client
        523  bytes received via SQL*Net from client
          2  SQL*Net roundtrips to/from client
          0  sorts (memory)
          0  sorts (disk)
          1  rows processed

因为在创建主键的过程中,需要取CON$表CON#列I_CON2索引上面的值,这个值即使我们真正要找的值。

在创建的时候找的是11589,因为11589记录在CON$上面(通过普通的select语句得到),但获取这个值得时候报错,因为其实需要的是11590。可以理解为CON#这个值由于oracle的bug或者其他原因没有更新进去,导致创建索引时获取到的键值与真正需要的键值不一致而产生ORA-01812这个错误。

接下里的思路就是将11589这个值改成11590。也就是出错的其实不是52号对象这个索引,而是存放11589的CON$这个内部表。

5. 定位CON$位置

找出CON$所在的文件号,块号,行号--》1号文件 289号block 12行

SQL> select con#,name,dbms_rowid.rowid_relative_fno(rowid) file#,dbms_rowid.rowid_block_number(rowid) block# ,dbms_rowid.rowid_row_number(rowid) row# from con$ where name='_NEXT_CONSTRAINT';

      CON# NAME                                FILE#     BLOCK#       ROW#
---------- ------------------------------ ---------- ---------- ----------
     11589 _NEXT_CONSTRAINT                        1        289         12

6. 查看trace中执行计划

通过搜索找到trace文件中的执行计划

============
Plan Table
============
--------------------------------------+-----------------------------------+
| Id  | Operation           | Name    | Rows  | Bytes | Cost  | Time      |
--------------------------------------+-----------------------------------+
| 0   | UPDATE STATEMENT    |         |       |       |     2 |           |
| 1   |  UPDATE             | CON$    |       |       |       |           |
| 2   |   INDEX UNIQUE SCAN | I_CON1  |     1 |    25 |     1 |  00:00:01 |
--------------------------------------+-----------------------------------+

Content of other_xml column
===========================
  db_version     : 11.2.0.4
  parse_schema   : SYS
  plan_hash      : 2574219287
  plan_hash_2    : 950544504
  Outline Data:
  /*+
    BEGIN_OUTLINE_DATA
      IGNORE_OPTIM_EMBEDDED_HINTS
      OPTIMIZER_FEATURES_ENABLE('11.2.0.4')
      DB_VERSION('11.2.0.4')
      OPT_PARAM('_optim_peek_user_binds' 'false')
      OUTLINE_LEAF(@"UPD$1")
      INDEX(@"UPD$1" "CON$"@"UPD$1" ("CON$"."OWNER#" "CON$"."NAME"))
    END_OUTLINE_DATA
  */
在创建主键的时候,oracle是要通过I_CON1索引去更新CON$下的CON#这个字段,然后把这个值赋值给主键,生成一个SYS之类的索引独享。

7. 根据trace文件中的rdba dump出52号对象这个唯一索引

SQL> alter system dump datafile 1 block 77798;

System altered.

SQL> select * from v$diag_info;
trace文件内容:

事务槽

 Object id on Block? Y
 seg/obj: 0x34  csc: 0x00.20835b  itc: 3  flg: O  typ: 2 - INDEX
     fsl: 0  fnx: 0x412fe7 ver: 0x01

 Itl           Xid                  Uba         Flag  Lck        Scn/Fsc
0x01   0x0007.020.000002bc  0x00c02b8e.0078.01  CB--    0  scn 0x0000.000fd5e0
0x02   0x000a.019.00000574  0x00c007f7.00bd.10  C---    0  scn 0x0000.0020834e
0x03   0x0008.008.00000668  0x00c0084a.01f2.0a  C---    0  scn 0x0000.0020799e
数据内容

row#3[2734] flag: ------, lock: 0, len=13, data:(6):  00 40 01 21 00 0c
col 0; len 4; (4):  c3 02 10 5b
----- end of leaf block dump -----
row#3:行号

data:(6):00 40 01 21 0c --》实际上这个就为存放数据的rowid。

转换为十进:1号文件,289号块,12行

SQL> select to_number('121','xxxxxxxxxx') from dual;

TO_NUMBER('121','XXXXXXXXXX')
-----------------------------
                          289

c3 02 10 5b即为索引要取的值,转换为十进制为:

SQL> select utl_raw.cast_to_number('c302105b') from dual;

UTL_RAW.CAST_TO_NUMBER('C302105B')
----------------------------------
                             11590
接下来就可以确定,把造成错误的原因就是,CON$中NAME为NEXT_CONSTRAINT,CON#为11590的这个值取不到,因为CON$即1号文件,289号块的第12行记录的为11589。

8. 使用BBED将11589改为11590

将c3 02 10 5a-->c3 02 10 5b即可

BBED> set file 1 block 289
        FILE#           1
        BLOCK#          289

BBED> map /v
 File: /u01/app/oracle/oradata/orcl/system01.dbf (1)
 Block: 289                                   Dba:0x00400121
------------------------------------------------------------
 KTB Data Block (Table/Cluster)

 struct kcbh, 20 bytes                      @0       
    ub1 type_kcbh                           @0       
    ub1 frmt_kcbh                           @1       
    ub1 spare1_kcbh                         @2       
    ub1 spare2_kcbh                         @3       
    ub4 rdba_kcbh                           @4       
    ub4 bas_kcbh                            @8       
    ub2 wrp_kcbh                            @12      
    ub1 seq_kcbh                            @14      
    ub1 flg_kcbh                            @15      
    ub2 chkval_kcbh                         @16      
    ub2 spare3_kcbh                         @18      

 struct ktbbh, 72 bytes                     @20      
    ub1 ktbbhtyp                            @20      
    union ktbbhsid, 4 bytes                 @24      
    struct ktbbhcsc, 8 bytes                @28      
    sb2 ktbbhict                            @36      
    ub1 ktbbhflg                            @38      
    ub1 ktbbhfsl                            @39      
    ub4 ktbbhfnx                            @40      
    struct ktbbhitl[2], 48 bytes            @44      

 struct kdbh, 14 bytes                      @92      
    ub1 kdbhflag                            @92      
    sb1 kdbhntab                            @93      
    sb2 kdbhnrow                            @94      
    sb2 kdbhfrre                            @96      
    sb2 kdbhfsbo                            @98      
    sb2 kdbhfseo                            @100     
    sb2 kdbhavsp                            @102     
    sb2 kdbhtosp                            @104     

 struct kdbt[1], 4 bytes                    @106     
    sb2 kdbtoffs                            @106     
    sb2 kdbtnrow                            @108     

 sb2 kdbr[311]                              @110     

 ub1 freespace[302]                         @732     

 ub1 rowdata[7154]                          @1034    

 ub4 tailchk                                @8188    


BBED> p *kdbr[12]
rowdata[0]
----------
ub1 rowdata[0]                              @1034     0x2c

BBED> x/rccnn
rowdata[0]                                  @1034    
----------
flag@1034: 0x2c (KDRHFL, KDRHFF, KDRHFH)
lock@1035: 0x00
cols@1036:    4

col    0[1] @1037: .
col   1[16] @1039: _NEXT_CONSTRAINT
col    2[4] @1056: 11589 
col    3[1] @1061: 0 


BBED> d /v offset 1056 count 16
 File: /u01/app/oracle/oradata/orcl/system01.dbf (1)
 Block: 289     Offsets: 1056 to 1071  Dba:0x00400121
-------------------------------------------------------
 04c30210 5a01802c 00040180 105f4e45 l .?.Z..,....._NE

 <16 bytes per line>

BBED> modify /x 5b offset 1060
Warning: contents of previous BIFILE will be lost. Proceed? (Y/N) y
 File: /u01/app/oracle/oradata/orcl/system01.dbf (1)
 Block: 289              Offsets: 1060 to 1075           Dba:0x00400121
------------------------------------------------------------------------
 5b01802c 00040180 105f4e45 58545f43 

 <32 bytes per line>

BBED> sum apply
Check value for File 1, Block 289:
current = 0xba00, required = 0xba00
重启后,即可正常创建索引

附上模拟ORA-08102错误的脚本:

SQL> create table t(id int,name varchar2(100));

Table created.

SQL> begin
  2  for i in 1 .. 5000 loop
  3  insert into t values(i,'test'||i);
  4  commit;
  5  end loop;
  6  end;
  7  /

PL/SQL procedure successfully completed.

BBED> set file 1 block 289
        FILE#           1
        BLOCK#          289

BBED> map /v
 File: /u01/app/oracle/oradata/orcl/system01.dbf (1)
 Block: 289                                   Dba:0x00400121
------------------------------------------------------------
 KTB Data Block (Table/Cluster)

 struct kcbh, 20 bytes                      @0       
    ub1 type_kcbh                           @0       
    ub1 frmt_kcbh                           @1       
    ub1 spare1_kcbh                         @2       
    ub1 spare2_kcbh                         @3       
    ub4 rdba_kcbh                           @4       
    ub4 bas_kcbh                            @8       
    ub2 wrp_kcbh                            @12      
    ub1 seq_kcbh                            @14      
    ub1 flg_kcbh                            @15      
    ub2 chkval_kcbh                         @16      
    ub2 spare3_kcbh                         @18      

 struct ktbbh, 72 bytes                     @20      
    ub1 ktbbhtyp                            @20      
    union ktbbhsid, 4 bytes                 @24      
    struct ktbbhcsc, 8 bytes                @28      
    sb2 ktbbhict                            @36      
    ub1 ktbbhflg                            @38      
    ub1 ktbbhfsl                            @39      
    ub4 ktbbhfnx                            @40      
    struct ktbbhitl[2], 48 bytes            @44      

 struct kdbh, 14 bytes                      @92      
    ub1 kdbhflag                            @92      
    sb1 kdbhntab                            @93      
    sb2 kdbhnrow                            @94      
    sb2 kdbhfrre                            @96      
    sb2 kdbhfsbo                            @98      
    sb2 kdbhfseo                            @100     
    sb2 kdbhavsp                            @102     
    sb2 kdbhtosp                            @104     

 struct kdbt[1], 4 bytes                    @106     
    sb2 kdbtoffs                            @106     
    sb2 kdbtnrow                            @108     

 sb2 kdbr[311]                              @110     

 ub1 freespace[302]                         @732     

 ub1 rowdata[7154]                          @1034    

 ub4 tailchk                                @8188    


BBED> p *kdbr[12]
rowdata[0]
----------
ub1 rowdata[0]                              @1034     0x2c

BBED> x /rccnn
rowdata[0]                                  @1034    
----------
flag@1034: 0x2c (KDRHFL, KDRHFF, KDRHFH)
lock@1035: 0x02
cols@1036:    4

col    0[1] @1037: .
col   1[16] @1039: _NEXT_CONSTRAINT
col    2[4] @1056: 11590 
col    3[1] @1061: 0 


BBED> d /v offset 1056 count 16
 File: /u01/app/oracle/oradata/orcl/system01.dbf (1)
 Block: 289     Offsets: 1056 to 1071  Dba:0x00400121
-------------------------------------------------------
 04c30210 5b01802c 00040180 105f4e45 l .?.[..,....._NE

 <16 bytes per line>

BBED> modify /x 5a offset 1060
Warning: contents of previous BIFILE will be lost. Proceed? (Y/N) y
 File: /u01/app/oracle/oradata/orcl/system01.dbf (1)
 Block: 289              Offsets: 1060 to 1075           Dba:0x00400121
------------------------------------------------------------------------
 5a01802c 00040180 105f4e45 58545f43 

 <32 bytes per line>

BBED> sum apply
Check value for File 1, Block 289:
current = 0xe0de, required = 0xe0de

BBED> p *kdbr[12]
rowdata[0]
----------
ub1 rowdata[0]                              @1034     0x2c

BBED> x /rccnn
rowdata[0]                                  @1034    
----------
flag@1034: 0x2c (KDRHFL, KDRHFF, KDRHFH)
lock@1035: 0x02
cols@1036:    4

col    0[1] @1037: .
col   1[16] @1039: _NEXT_CONSTRAINT
col    2[4] @1056: 11589 
col    3[1] @1061: 0 




Oracle故障处理之ORA-08102索引键值不存在 文章目录问题描述问题分析解决方案1. 重建索引2. 检查索引必要性 问题描述 香港客户有一套日本开发的全球系统,它采用的数据库是Oracle Database Standard Edition 10.2.0.5。系统侧抛出错误参考如下: Ora-08102:index key not found, obj# 145664, file 12, block 3326692(2) 问题分析 检查问题对象信息 col object_name format a15; col owner format a10; 阅读详情

相关推荐

Matlab实战:3种雷达间歇采样干扰的仿真与识别(附完整代码)

本文通过Matlab实战,详细仿真了雷达有源间歇采样干扰的三种核心样式:直接转发、重复转发和循环转发干扰。文章提供了完整的代码实现,并深入探讨了基于时频分析和循环平稳分析的特征提取与识别方法,为雷达抗干扰技术的学习与实践提供了清晰的工程实现路径。

weixin_29053695的博客 342

ORA-08102: 未找到索引关键字

问题:ORA-08102: 未找到索引关键字, 对象号 152365, 文件 32, 块 858965 (2)1、根据对象号查询到索引名称(object_name)2、执行 alter index

qq_42369541的博客 1184

极验滑块验证码破解与研究(一):AST还原混淆JS

极验滑块验证码破解与研究(一):AST还原混淆JS声明一、环境安装1. node安装1.1. node下载1.2. 配置环境变量1.3. node安装检测1.4. pycharm配置node环境2. babel库安装2.1. babel库安装命令2.2. babel库安装检测二、AST还原混淆JS1. 模块导入2. AST还原流程3. 复制还原需要用到的js源码4. AST还原函数详解4.1. replace_unicode4.2. replace_unicode, replace_name_array,

帯泪的鱼的博客 1万+

ORA-08102原因分析及处理

执行truncate partition时报错: SQL> alter table EC_IOM_OCMDRDER_TBL truncate partition E_I_O_T_2009_APR update globa...

721

Oracle 常见错误代码处理 08102-32001

ORA-12899 实际值 2 最大值 1 1、ORA-12899: value too large for column "ELEMENT"."BAS_PERSON_IMP"."SEX_CODE" (actual: 2, maximum: 1) 2、这是因为存储内容超出了字段的长度 ,比如 sex_code varchar2(1),则插入 1或者2可以,而插入男或女就会报错,因为 Oracle 中一个汉字占两个长度。 ...............

蚩尤后裔-汪茂雄 7136

断电引起的ORA-08102: 未找到索引关键字, 对象号 39故障处理---惜分飞

最近有客户在虚拟化平台运行oracle,由于机房掉电,导致oracle数据库无法正常启动,通过第三方恢复,oracle被强制拉起,但是无法进行ddl操作,比如创建表报ORA-08102: 未找到索引关键字, 对象号 39, 文件 1, 块 122448 (2) 错误。处理完上述两个明显故障之后,然后使用expdp不落地方式把客户数据迁移到新库,完成本次恢复任务。这个问题解决之后,该客户还有另外一个问题需要解决(不然数据库运行一段时间之后就会crash)

445

解决ORA-08102: index key not found

ORA-08102: index key not found, obj# 304067, dba 33580767 (2)oerr ora 810208102, 00000, "index key not found, obj# %s, dba %s (%s)"// *Cause: Internal error: possible inconsistency in index// *Actio

Leo's DBA blog 2307

作业删除不了 警告文件:ORA-08102: index key not found, obj# 239

You are trying to manipulate a job in the job queue(DBA_JOBS/USER_JOBS) and you receive:ORA-08102: index key not f...

cuirenyun9144的博客 232

ORA-08102:index key not found, obj# 52485, file 19,block 399461 (2)

今天做一条update语句,结果报错如下 ORA-08102:index key not found, obj# 52485, file 19,block 399461 (2) 查询 SELECT * FROM Dba_Objects WHERE object_id =52485; 得到一个index名称XXX.XXX 先尝试重建索引 alter index XX...

yuzhenhuan01的专栏 806

ORA-08102: index key not found, obj# 129038, file 78, block 2910787 (2)

表的索引发生发生问题   查询发现obj#239是索引I_JOB_NEXT 。   SQL> col object_name format a15; SQL> col owner format a10; SQL> select o.owner, o.object_name, o.object_id, o.object_type   2    from dba_objects

yasuuu.taobao.com 2121

ora-08102:index key not found,obj#57848,file 6, block 6324(2)

author:skatetime:2009/11/2 今天两次遇到ora-08102的错误,在删除表的数据时 在执行如下语句时:delete from tb_ware w where w.issue like %04%; 遇到下面的错; ora-08102:index key not found,obj#57848,file 6, block 6324(

冰刀(skate) 3820

ORA-08102: index key not found, obj# 56687, file 54, block 176049 (2)

delete from B2BADMIN.DELIVERYJOB where DOCID in(SELECT DOCID from B2BADMIN.BIZDOC where doctimestamp< sysdate -...

cuixie2370的博客 174

java.sql.SQLException: ORA-08102: index key not found, obj# 80756, file 18, block 35018 (2)

昨天使用vnc登陆linux时居然没有响应,就把liunx重启了。 结果悲剧了,今天ssh到linux去启动weblogic10的domain,居然报了 java.sql.SQLException: ORA-08102: index key not found, obj# 80756, file 18, block 35018 (2) 的错误,百度后,发现已有解决方案

GreyCode的专栏 163

*** KEWROCISTMTEXEC - encountered error: (ORA-08102: index key not found, obj# 8965, file 3, block ...

早上来公司一看。以为不会出什么问题。 检查日志 Errors in file /u01/app/oracle/admin/gs/bdump/gs2_m000_11862398.trc:Mon Nov 14 07:05:44 2011Trace dumping is performing id=[cdmp_20111114070544] ---------------trc文件--------...

weixin_30852367的博客 201

shell 获取ora报错信息_ORA-08102 index key的错误恢复

一 总体描述自己的实验虚拟数据库中的alert不停的报下面的错误.alert日志刷的闹心.Sun Jun 10 23:44:42 2012Errors in file /u01/app/oracle/product/10.2.0/db_1/admin/testb/bdump/testb_j000_4944.trc:ORA-00604: error occurred at recursive SQL...

weixin_39980347的博客 157

执行job时出现错误ORA-08102

昨天在做定期清理job的时候出现ORA-08102的错误 BAK.PKG_CLEAN.PROC_MS_CLEANfailed: ORA-08102: index key not found, obj# 58401, file 69, block 447746 (2) --查看58401这个对象具体是什么 SELECT owner, object_name, object_type FRO

Sharon--start focusing on Oracle 2120

ora 06512是什么错误_ORA-08102 index key的错误恢复

一 总体描述自己的实验虚拟数据库中的alert不停的报下面的错误.alert日志刷的闹心.Sun Jun 10 23:44:42 2012Errors in file /u01/app/oracle/product/10.2.0/db_1/admin/testb/bdump/testb_j000_4944.trc:ORA-00604: error occurred at recursive SQL...

weixin_29358723的博客 280

ORA-08102 index key的错误恢复

一 总体描述自己的实验虚拟数据库中的alert不停的报下面的错误.alert日志刷的闹心.Sun Jun 10 23:44:42 2012Errors in file /u01/app/oracle...

cnk45946的博客 127
上一篇: Oracle11gR2手工建库(附DBCA静默建库)
下一篇: 普通用户使用set autotrace
bitko
博客等级 码龄12年 149粉丝 337原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值