SQL2005附加数据库,提示 数据库 版本为655,无法打开,此服务器支持611版本或更低版本。错误为948

【低空经济】森林火情高精度监测与早期预警无人机巡护方案 在全球范围内,森林火灾已成为一个严重的生态和社会问题。它不仅对自然生态系统造成了毁灭性的影响,还对人类的生命财产安全构成了极大的威胁。根据国际森林发展组织的统计,全球每年因森林火灾造成的经济损失高达数百亿美元,甚至在某些年份,火灾损失占到某些国家国民经济总量的相当一部分。因此,开展高效的森林火情监测与早期预警工作显得尤为重要。随着科技的发展,无人机作为新兴的监测工具,以其高效、灵活和经济的特点在森林火灾监测领域展现出了巨大的潜力。 阅读详情
SQL2005附加数据库,提示 数据库 版本为655,无法打开,此服务器支持611版本或更低版本。错误为948

附加数据库 遇到如下问题:

数据库 'SqlPersistenceService' 的版本为 655,无法打开。此服务器支持 611 版及更低版本。不支持降级路径。 无法打开新数据库 'SqlPersistenceService'。CREATE DATABASE 中止。

原因:

版本655指的是SQL2008, 版本611指的是SQL2005, (还有一个版本539指的是SQL2000)
楼主的情况属于典型的从高版本降低至低版本使用的情景.
按微软的官方说法, 是不支持从高版本附加到低版本的.
如果一定要这么做, 那怎么办呢? 有办法.
首先, 找一台装有SQL Server 2008的电脑, 将你的数据库文件附加到这台电脑里.
附加成功后, 在SSMS的对象资源管理器窗口右键单击刚刚附加的数据库,依次选"任务>生成脚本...", 此时会弹出脚本向导对话框.
点"下一步".
在"选择数据库"对话框选中刚刚附加的数据库, 同时将底部的"为所选数据库中的所有对象编写脚本"打勾. 点下一步.
在"选择脚本选项"对话框中,还需要修改以下几个选项:
1)."编写数据的脚本",设为"True"; (SQL2005没有这个选项,所以才要找一台装有SQL2008的电脑嘛,多省事啊,省去了数据导入导出的麻烦)
2)."编写触发器脚本",设为"True";
3)."编写创建数据库的脚本",设为"True";
4)."为服务器版本编写脚本",选"SQL Server 2005";(如果是要用的SQL2000中,那就选SQL Server 2000)
以上4个选项是非常建议这样设置的,其他的选项就自己看着办,其他的一般也不用改. 点下一步.
在"输出选项"对话框中,选"将脚本保存到文件",其他默认,点下一步.
点完成.
点关闭.

然后将刚刚生成的脚本文件拷到你自己的电脑上,在SQL Server 2005中打开并执行该脚本.!!!注意:在执行该脚本前,如有必要,请务必修改该脚本中指定的mdf文件和ldf文件的物理路径,以符合你自己的要求.


QT+SOEM主站协议库实战指南—从编译到嵌入式应用 本文提供了一份QT与SOEM开源EtherCAT主站协议库的集成实战指南。详细介绍了在Windows和Linux平台下编译SOEM库的步骤,并讲解了如何将其无缝集成到QT项目中,构建具备实时监控与控制功能的工业上位机应用。内容涵盖从环境搭建、核心协议开发到嵌入式部署与优化的全流程,为开发高性价比、自主可控的工业控制解决方案提供完整路径。 阅读详情

相关推荐

【数据集2】CPC Global Unified Temperature/Precipitation数据简介及处理

简介CPC 温度及降雨 数据

WW、forever的博客 3070

数据库 'SqlPersistenceService' 的版本655无法打开。此服务器支持 611 版及低版

附加数据库 遇到如下问题:数据库 SqlPersistenceService 的版本655无法打开。此服务器支持 611 版及低版本。不支持降级路径。 无法打开数据库 SqlPersistenceService。CREATE DATABASE 中止。 原因:版本655指的是SQL2008, 版本611指的是SQL2005, (还有一个版本539指的是SQL2000)

backslash的专栏 8786

华为OD机试双机位C卷-恢复数字序列 (Py/Java/C/C++/Js/Go)

华为OD机试双机位C卷 恢复数字序列,提供C语言、Java、C++、Python、Go、JavaScript源码实现,并提供完整思路讲解。华为OD机试 - 恢复数字序列。

qq_45776114的博客 1174

服务器支持661版及低版本。不支持降级路径。

服务器支持661版及低版本。不支持降级路径。 环境: SQL Server 2008 R2. 问题: 附加数据库报错“此服务器支持661版及低版本。不支持降级路径。” 解决方案:         出现这样的问题,一般是因为数据库版本不同造成的。         查询数据库版本语法: use master select @@VERSION 661sql2008 R2的

NetSuite 张老师 6410

关于SQL Server附加数据库提示版本661无法打开支持高级版本,不支持降级路径,数据库附加不上的问题

关于SQL Server附加数据库提示版本661无法打开支持高级版本,不支持降级路径,数据库附加不上的问题

qzy的博客 8638

The database ‘xxx.mdf‘ cannot be opened because it is version 904. This server supports version 655

Visual Studio 2019连接SQL Server 2019LocalDB

weixin_35214138的博客 2247

SQL sever 附加数据库提示"版本611支持版本655"——机房重构(一)

终于重构了

飞老虎 1万+

数据库 'ServerDB' 的版本655无法打开。此服务器支持 611 版及低版本

今天在公司还原从客户拷贝的数据库文件时,提示无法还原数据库错误信息为: 数据库 'ServerDB' 的版本为 655无法打开。此服务器支持 611 版及低版本。不支持降级路径。 无法打开数据库 ServerDB。CREATE DATABASE 中止。错误代码:948. 仔细查看一下相关资料,找到问题及解决办法以供参考。 几类常用数据库版本主要包括: SQL Server 2005

Robin022的专栏 1万+

mysql 错误948_SQL错误948解决办法

SQL错误948解决办法(2011-06-22 17:53:35)标签:杂谈附加数据库 遇到如下问题:数据库 'SqlPersistenceService' 的版本655无法打开。此服务器支持 611 版及低版本。不支持降级路径。 无法打开数据库 'SqlPersistenceService'。CREATE DATABASE 中止。原因:版本655指的是SQL2008, 版本611指的是...

weixin_36379029的博客 2499

mysql 错误948_SQL Server 2008,错误948虽然附加数据库出现版本错误

昨天我在我的笔记本电脑上安装了SQL Server 2008(Windows 7 64位),我需要将.mdf附加服务器,但是当我尝试这样做时,我收到此错误:为服务器'prince / sqlexpress'(Microsoft.SqlServer.smo)附加数据库失败其他资料:1.执行Transact Sql语句批处理(Microsoft.SqlServer.connectioninfo)时...

weixin_35654499的博客 1248

sql server 2008 附加数据库提示 错误948

版本655指的是SQL2008, 版本611指的是SQL2005, (还有一个版本539指的是SQL2000) 楼主的情况属于典型的从高版本降低至低版本使用的情景. 按微软的官方说法, 是不支持从高版本附加低版本的. 如果一定要这么做, 那怎么办呢? 有办法. 首先, 找一台装有SQL Server 2008的电脑, 将你的数据库文件附加到这台电脑里. 附加成功后, 在SSMS的对象资

Mindy的专栏 1万+

Microsoft SQL Server 错误948 5120 5133

Microsoft SQL Server 错误948 版本655指的是SQL2008, 版本611指的是SQL2005, (还有一个版本539指的是SQL2000) 楼主的情况属于典型的从高版本降低至低版本使用的情景. 按微软的官方说法, 是不支持从高版本附加低版本的. 如果一定要这么做, 那怎么办呢? 有办法. 首先, 找一台装有SQL Server 2008的电脑, 将你的数据库文件附

dingxingmei的专栏 5542

sqlserver2005-error:948

sqlserver 中第948错误的解决办法 655指的是SQL2008, 版本611指的是SQL2005, (还有一个版本539指的是SQL2000) 楼主的情况属于典型的从高版本降低至低版本使用的情景. 按微软的官方说法, 是不支持从高版本附加低版本的. 如果一定要这么做, 那怎么...

weixin_34187822的博客 212

Microsoft SQL Server 错误948

Microsoft SQL Server 错误948 版本655指的是SQL2008, 版本611指的是SQL2005, (还有一个版本539指的是SQL2000) 楼主的情况属于典型的从高版本降低至低版本使用的情景. 按微软的官方说法, 是不支持从高版本附加低版本的. 如果一定要这么做, 那怎么办呢? 有办法. 首先, 找一台装有SQL Server 2008的电脑, 将你的数据库文...

weixin_33796177的博客 1427

SQL server 数据库版本661,不支持降级路径

在我们使用别人导出的数据库的时候,有时候我们会通过附加数据库的方法,把别人导出的数据库附加到我们的电脑中,这时,许你会遇到这种问题,附加时,提示版本为XXX,无法打开支持AAA版本。       这是怎么回事呢?       原来,版本号是指SQL Server版本号,例如版本661SQL Server 2008 R2,版本655SQL Server 2008 等

qian_guan的博客 1万+

如何处理SQL Server附加数据库时出现的错误

处理附加数据库时,出现无法升级数据,版本不兼容问题的解决办法

ZCYaiCLX3344的博客 2万+

数据库还原可疑.无法打开数据库'XX'版本 611.请将该数据库升级为最新版本.

在网上找了个数据库,在自己的sqlserver 2008 r2 上还原,出现错误,似乎版本不同! 还原不成功,取消后还是出现数据库了,但是处于【可疑】状态,无法查看和使用!

1万+

附加数据库失败 版本661无法打开支持655版本解决方法

SQL sever 2008附加原来的数据库的时候却出现了这样的问题,如下图: 然后就去查资料了,原因是SQL Sever 2008的版本号为655SQL Sever 2008 R2的版本号为611,这句话就是是说我的服务器(本机)的SQL Sever 2008版本低于创建该数据库用到SQL Sever的版本(就是你用的数据库版本过时了),解决方法么就是最简单的下载一个SQL ...

Hello World 5402

附加数据库时:数据库版本661无法打开。此服务器支持655 版及低版本。不支持降级路径。

出现这个问题是因为要附加数据库sql2008R2生成的,sql2008R2的版本号是661,而本地的数据库可能是sql2008(版本655者是比sql2008R2底的版本。解决办法就是下载一个sql2008R2的安装包升级一下数据库。地址如下: 1. SQL Server 2008 R2 Developer (x86, x64, ia64) – DVD (Chinese-Sim

歆萌的专栏 1万+
上一篇: MD5加密
下一篇: 数据绑定以及Container.DataItem几种方式与用法分析 .
slowlifes
博客等级 码龄15年 354粉丝 19原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值