cognos软件安装及其他问题

开发者福利!热门AI工具限时免费用 购周边即赠Coding Plan Lite,Claude Code、Cursor等20+工具畅享,效率翻倍! 阅读详情
1. cognos的日志存储在哪里。
COGNOS日志默认的位置在..cognoscer1;你可以在Transformer中设置日志位置。


2. 如果是采用b/s方式,大虾都用cognos的什么工具来定制一些报表,怎么发布到网上?
一般使用impromptu定制,使用impromptu web report发布
不然就像前边别的论坛一个朋友所说,做“powerplay报表”,用powerplay enterprise server发布ppx文件


3. COGNOS 的安装顺序如下:
1。安装DIRECTORY SERVER,一般可使用默认配置参数,并且记住这些参数。
2。运行ENTERPRISE SERVER ADMINISTRATION的安装光盘,在该安装界面上运行CONFIG THE DIRECTORY SERVER进行配置,使用上一步的参数进行DIRECTORY SERVER的配置。
3。 安装ENTERPRISE SERVER ADMINISTRATION,使用上以上的配置(都使用默认值即可),安装完毕后,打开ACCESS MANAGER可看到默认得DIRECTORY SERVER,如果没有,可点击右键加入,测试成功后打开TICKET SERVER TAB页,使用默认配置,测试通过,打开RUNTIME CREDENTIALS TAB页,测试通过后点击“确定”按钮。
4。安装完毕后打开IE,输入http://LOCALHOST/COGNOS/CGI-BIN/PPDSCGI.EXE,可看到COGNOS发布CUBE的主页。如果打不开,可检查虚拟目录是否加入COGNOS/CGI-BIN。
5。打开UPFRONT SERVER ADMINISTRATON,加入服务器,使用默认本机即可,安装完毕。打开IE,输入http://LOCALHOST/COGNOS,可看到COGNOS的UPFRONT 地配置主页。如果打不开,可检查UPFRONT服务是否起来。
6。其他安装比较简单,只不过注意安装POWERPLAY TRANSFORMER 时只安装SERVER即可,不需再安装USER版,如果安装USER版可能会将SERVER冲掉。IMPROMPTU的SERVER和USER版均可安装,但一般SERVER版足够了。
7。 COGNOS权限控制如下:加入用户组只可以在ACCESS MANAGER中进行,而加入用户既可以在ACCESS MANAGER中进行,也可以在UPFRONT的WEB界面上进行。一般用户和用户组在ACCESS MANAGER中处理,而对资源的控制在UPFRONT 的WEB界面中进行。
8。COGNOS的DS只做数据处理,但可以调用存储过程,程序调度仍在SCHEDULER中处理,可先将数据处理的DS作业流和CUBE的调用写成批处理,然后在SCHEDULER中调度。
9。COGNOS6.61可生成动态定制报表.ppx文件,并可以在WEB上发布。
10。UPFRONT的WEB界面可以修改,需要JSP和XML技术。


4. Cognos不支持EIS?
cognos的EIS产品是visualizer


5. 不知Cognos针对大容量的应用环境其性能如何?比如移动经营分析系统,请行家给出建议。
数据量大一些不要紧,关键在于你的模型设计是否优化,如维不要多,维的LEVEL与CATEOGRY也不要过多。此外可以试着使用TRANSFORM对CUBE进行分区优化

6. Impromptu 6.0安装问题?

错误现象:

1)我在安装Impromptu 6.0 (Administrator Edition)临近安装结束时,系统提示“无法定位程序入口点nlsStrqcmpn2于动态连接库COMML.DLL上”。

2)在Temp目录下看到下列错误日志:
Failed to self-register the file: C:Cognoscer1binxxxAutoMetaDataCache.dll.
The installation will continue, but you will need to reboot your system in order for the self-registration to work.
Custom action failed. Library: .SetDSN.dll - Function: AddDSN - Arguments: DB_GREATOUTDOORS

3)我的PowerPrompt的tools菜单下的run用不了

在安装此程序前,我已经停止了所有Cognos服务。谁能帮我解答此类问题?


产生原因:
1)没有停止所有以Cognos开头的服务停止
2)没有停止所有以Impromptu开头的服务停止
3)没有停止Netscape Administration Server 4.2服务
4)没有停止Netscape Directory Server 4.1服务
5)没有退出Cognos Common logon

7. 在Web展现方面,Brio,BO,Cognos都是通过什么方式实现的?
Cognos使用Powerplay Enterprise Server来提供基于WEB方式的CUBE访问。
Impromptu Web Report提供Impromptu报表的Web访问
Upfront Server类似于企业或个人门户,用于将Cube及Report集成起来(只是将他们的访问链接集成起来,但真正的CUBE处理或报表处理还是要转向相应的SERER),形成完整的系统。

所有的WEB访问都是通过CGI形式

8. 有没有觉得schedule定时执行时,会偶尔失灵呀
而且还谎称NO ERRORS
定时刷新立方体
用windows自带的计划任务吧

9. Netscape安装到最后出现注册失败
不能通过网络硬盘安装

安装文件要在本地,把防毒的都给我关掉

安装时最好两个密码一致

我现在也没有搞清楚那两个密码有什么作用,呵呵,不好意思,我初学
一般不要把netscape directory与操作系统装在一个盘。
Netscape安装到最后,一切正常,就是无法登陆。
后来重启服务(Netscape的三个服务都重启),就可以登陆呢。不知道为什么?百思不得其解。我装在E盘,分区是NTFS。
后来整个Netscape都重装,又好了
10. 下面的是最简单的cognos自动登陆实现文档.在安装过cognos的机器上,如果初始用户名和密码都没有改变,可以实现自动登陆.这里说一句,cognos的技术支持太薄弱了,什么都要用户自己摸索,为什么不开放些,也好有利于自己的发展.
目前cognos被客户批的厉害,估计下面cognos的销售情况会有较大的波动.谁让他不开放的!

<html>
<head>
<title>无标题文档</title>
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<script language="Javascript">
var requestSubmitted = false;
function autosubmit()
{
document.login.submit();
}
</script>
</head>

<body bgcolor="#FFFFFF" text="#000000">
<!-- 这里的action填上http://你的主机名或ip地址/cognos/cgi-bin/login.cgi?" method=POST -->
<form name="login" action="http://localhost/cognos/cgi-bin/login.cgi?" method=POST >
<input type=hidden name=NamespaceTitle value='>
<input type=hidden name=pwdCaseSensitive value='Yes'>
<!-- 这里value的值填上http://你的主机名或ip地址/cognos/cgi-bin/upfcgi.exe?xmlcmd=<GoHome/>,实际中还可以更复杂的链接-->
<input type=hidden name=return_url value='http://localhost/cognos/cgi-bin/upfcgi.exe?xmlcmd=<GoHome/>'>
<input type=hidden name=cancel_url value='http://localhost/cognos/cgi-bin/upfcgi.exe?xmlcmd=<GoHome/>'>
<input type=hidden name=namespace value='default'>
<input type=hidden name=action value='login'>
<input type=hidden name=loginfailed value='1'>
<input type=hidden name=databaseDisplay value='>
<input type=hidden name=guest_url value="">
<!-- 在cognos的登陆脚本中,上面的几个hidden代码是由login.cgi根据服务器运行宏生成的 -->
<!-- 这里的value使用保存过的用户登陆名 -->
<input type="hidden" name="signon" value="administrator">
<!-- 这里的value使用保存过的用户密码 -->
<input type="hidden" name="password" value="">
<!-- 实际使用中,合理利用cookie或其他方法,取得用户在其他地方输入的用户名和密码,发送给login.cgi就可以实现自动登陆了 -->
</form>
<script language="Javascript">autosubmit()</script>
</body>
</html>

11. 不装improtu,是否可以装enterprise server

我的improtu给坏了,马上要做演示,请问不装improtu,是否可以装enterprise server和transform 。我只想在IE方式下浏览即可,该怎么办?



可以的
Impromptu一般不会坏,你可以删除cer1binimpromptu.ini,在启动impromptu应该就可以了。


12. Cognos对外编程接口调用方法(VB,VC)

Steps to use the Type Library in Visual Basic
1. Open a project.
2. From the Project menu, click References.
3. In the Available References box, select the CognosTransformer check box and click OK.
Note: If the entry isn't in the list, click Browse and select Transaut.tlb from the Bin folder
where you installed Transformer.
4. From the View menu, click Object Browser.
5. From the Library list (in the top left corner), click Cognos Transformer.
6. Find the object or collection you want, and select the corresponding methods and properties.
7. Use these methods and properties in your macro.
Steps to use the Type Library in Visual C++
1. Open Developer's Studio.
2. Open a project.
3. From the View menu, click Class Wizard.
4. Click Add Class and then click From a Type Library.
5. Select Transaut.tlb.
6. In the Confirm Classes box, click the classes you want and click OK.
7. Click Class View, to view the selected classes and their objects in the Workspace.
8. Click File Viewer to view the object definitions in the Transaut.h file.
You can now create objects in implementation files (.cpp).

13. 请问Rollup是什么意思

请教各位前辈
regular rollup
time state rollup
duplicates rollup
三者的含义,
定期积累;
按时积累;
成倍积累;




14. 大家有遇到安装Transform到一半不允许继续安装的情况的吗?

大家有遇到安装Transform到一半不允许继续安装的情况的吗?
一般不会

你记得安装的 时候停止你的防病毒的防火墙(特别是金山毒霸),在重新安装的时候将注册表里面相关的删除干净。就应该没有问题了
15. 好像不是太符合实际情况

在Cognos中可以使用的数据源分为内部和外部两种。
外部数据源:可以使用Excel、dbf文件、文本文件(没试过)作为数据源使用,比如可以使用一个包括各种货币转换的Excel表作为一个数据源。
内部数据源:使用Cognos工具生成的数据源,比如用Impromptu,将Imr文件另存为iqd文件作为数据源使用。

cat文件只是用来确定信息目录使用,不能算作数据源。
具体各种数据源的添加方式可以参见我以前上传的PowerPlay使用手册。
16. 关于安装‘IWR’ 的问题--报表发布

安装‘IWR’后,服务:
Impromptu Web COM Service (CER1)
Impromptu Web Service Manager (CER1)
启动出错!
提示:
错误1053:服务并未及时响应启动或控制请求!

请高手指点!谢谢!!
查看Impromptu Web COM Service (CER1) ,Impromptu Web Service Manager (CER1) 依存关系中依赖服务都起了吗


WIN200 SERVER 中安装IWR过程没提示异常情况,
我的安装顺序:
1、安装NETSCAPE;
2、安装IWR光盘的SETUP;
3、安装完毕上述两服务不能启动。
请问:上述安装是否正确?

安装NETSCAPE完后,要 运行configure directory server
你的机器是奔4处理器吗?
安装的时候有没有出现过报错?
我刚开始安装IWR的时候按默认的方式安装,要报错;
但后来咨询熟悉的人员,被告知需自定义安装,且只安装第一项,其他项在安装其他设备时也要安装的。结果果然没报错,而且服务启动正常。

17. 在ldap中读出来的中文字符显示不正常?

cognos用的什么字符集?
通常是KaiTi_GB2312和SimSun两种,都是cp936的编码


18. 有关Netscape的安装

在P4上安装Netscape时,报错
Error execuiing installation program C:NetscapeServer4binslapdadminbinindex.exe;An unknow error occured while creating the directory server .Check the server logs for details
请各位大虾帮忙

Netscape 的安装不能通过终端管理器安装


19. impromptu web reports 6.0安装求助

OS:WIN2K SERVER SP4
已经安装成功了:POWERPLAY,NETSCAPE,POWERPLAY ENTERPRISE SERVER,IMPROMTU ADMINISTRATOR等,安装IWR时报错,IWR_DB未能建立?各位,是什么原因?
为administrator增加dcom的访问属性

步子:
1。运行 cmd>c:winntsystem32dcomcnfg.exe
2。为administrator增加dcom的访问属性

20. cognos7.1的配置问题

我想试试看cognos7.1安装,如下步骤,请指教一下。
由于我只想装服务器。
1、netscape directory server 4.2
2、powerplay enterprise server
3、configuratrion manager出现一错误,是怎么回事?

unable to determine error that occurred trying to run command upfunpack.bat ix UpfUnpackError.log


重新安装,安装的时候,在选择语言时,不要选择默认的,选择下面一个,然后一路安装下去。
去cognos-shared-locale中将locale的语言设置改成En-GB就可以了。

21. failed activation of data store
failed activation of server
unable to determine error that occurred to run command upfunpack.bat -x upfunpackerror.log
Cognos的审计日志审计报表 Cognos审计日志是对系统事件、用户行为的详细记录。我们可以使用审计日志回答“谁在什么时候对某个组件做了什么操作”的问题Cognos可以将审计信息记录到不同的介质中,最常用的两种记录介质是文件系统审计数据库。 阅读详情

相关推荐

安装配置ESRI Maps For Cognos

安装配置Vantage 该软件使Cognos可以使用第三方的插件,所以在安装ESRI Maps For Cognos前需要首先对其进行安装配置 Vantage安装 以管理员身份运行CMD,定位到安装文件的Vantage目录,执行lauchInstallerC10_1_1.bat就可以看到左边的安装界面如下: 注: 84对应Cognos8.4版本,10对应Cognos10版本,*.

esricd的专栏 2757

cognos常见错误解决方案汇总.doc

cognos常见错误解决方案汇总

安装cognos BI&Transformer常见报错合集大纲

本文总结了Cognos相关系统的常见问题及解决方法:1)界面启动失败时需安装远程桌面VNC;2)Oracle连接报错需迁移32位客户端依赖包;3)字符集问题可通过修改locale.conf并生成locale文件解决;4)PermGen Space错误需更换JDK8;5)需按用户调整httpd.conf配置;6)Windows下Transformer闪退需安装微软运行库;7)数据编码错误可通过设置环境变量NLS_LANG解决。

weixin_42246470的博客 368

COGNOS getFormWarpRequest 实例

COGNOS getFormWarpRequest 实例

Cognos常见错误解决办法

说明:这里面有别人的总结,也有我自己的经历,总结一下,以免以后再遇到又摸不到头脑 1、Cognos不能使用Excel打开   解决方法一:     1. 打开IE浏览器,在工具条中找到工具栏--àIntenet选项-à安全--à受信任的站点   2.点击站点,添加可信任站点http://localhost:9080/p2pd/servlet/dispatch   注意

Anthony.Hust 1万+

使用CubeIDE的一些经验(代码补全、声明/定义跳转、搜索)

如果是在函数内(大括号内)使用快捷键【Alt + /】,那它可以很好地发挥作用。但是如果是在函数外(大括号外)使用快捷键【Alt + /】,那么它提示的内容中,只有使用typedef重新命名的内容以及宏定义的内容,其他的,函数、枚举量什么的,不会出现在提示框内。声明/定义跳转快捷键是【F3】或者【ctrl + 鼠标左键】,个人测试,感觉【F3】【ctrl + 鼠标左键】的效果是一样的。快捷键【Alt + /】的使用是有限制的。下图中选中的是【content assist】,即【代码补全】。

weixin_63096487的博客 1万+

cognos安装启动遇到的问题详解一

cognos遇到的一些问题避坑安装进入主界面cognos的配置配置cognos的数据源启动cognos设置数据源oracle32位客户端的安装方法再次测试 避坑 由于用到cognos报表着实被这个坑到了,现在分享出来避免大家入坑。 安装 可以参考这个:图文安装 这里说明下:第五步骤的时候, 这里说的是cognos自带的数据源,直接不勾选,反正也用不到,如果勾选了后面还得手动删除,麻烦。 进入主界面 cognos的配置 打开Environment页面,修改Gateway URIGateway name

隔壁张同学 1337

cognos安装过程各种问题跟解决方法

cognos安装过程各种问题跟解决方法

dearbaba_8520的博客 201

cognos 问题汇总(转载),稍后会上自己的总结

1. cognos的日志存储在哪里。COGNOS日志默认的位置在..cognoscer1;你可以在Transformer中设置日志位置。2. 如果是采用b/s方式,大虾都用cognos的什么工具来定制一些报表,怎么发布到网上?一般使用impromptu定制,使用impromptu web report发布不然就像前边别的论坛一个朋友所说,做“powerplay报表”,用po

a506690的专栏 5790

Cognos安装出现的“该软件要求使用Windows NT 4.0 或更高版本。无法在此计算机上安装问题...

在win 7 64位或是win 7 32位安装Cognos 8.3版本时碰到这样的问题,弹出窗口“该软件要求使用Windows NT 4.0 或更高版本。无法在此计算机上安装”。 [img]http://dl.iteye.com/upload/attachment/0079/0027/5a55df44-72e8-3715-a49e-1777df80986e.png[/img] ...

kekafei的博客 2279

在RHEL5.5下安装Cognos 10.1 缺少 libXm.so.3解决方法

今天为了给客户提供一份Cognos备份及恢复的文档,决定在RHEL 5.5上安装Cognos10.1, 并进行测试备份及恢复。大致过程如下: 1、准备软件包 bisrvr64101ml.iso 2、挂载iso...

cilicao5089的博客 594

cognos的恶梦般的缺陷

Cognos没有Java编程接口,也没有.net编程接口,还不支持MDX,仅有的VB接口也糟糕透顶。Cognos PowerPlay维度的权限设置真是要累死系统管理员。Cognos Web版居然使用古老的CGI,系统慢的要死。Cognos的父子层次必须唯一,层次改变后Cube不会自动修改,不得不手工删除,自动删除实现就那么难吗?Cognos IWR发布报表的步骤太复杂。最重要的cognos安装

BI 商业智能 的专栏 2473

CFG-ERR-0106 IBM Cognos Configuration在指定时间内未收到IBM Cognos服务的响应。

开始安装cognos10.1,也遇到了这个问题,就是环境变量的事情,这次a

sisiiiiiii的专栏 4595

Install 32bit 11.2.0.3 client on 64bit redhat 6.2需要(i386)解决方法

Install 32bit 11.2.0.3 client on 64bit redhat 6.2需要(i386)解决方法     IBM安装Cognos的工程师,要求我们现有的一台64bit redhat 6.2的服务器安装 32bit 11.2.0.3 client。安装一个32 client 在64bit的服务器本来是一项DBA的日常工作,今天竟然卡了一天。真是郁闷之极。  

783

Cognos安装配置--单机环境

大家也知道,Cognos是一个企业级的BI开发工具,是一个高并发,大规模的报表平台应用。 所以来说Cognos服务器是以一个集群方式来安装的。 由于个人学习目的,在单机环境中进行安装,在此做个简单的介绍cognos安装。首先简单说明一下安装所需要的软件Cognos BI Server 64-bit Cognos Clinet 32-bit (Framewor

yangpingping94的博客 1459

COGNOS安装笔记

 1、reportnet资料库安装reportnet必须有一个资料库(content store)来存储相关的信息。可以用oracle,DB2, SQL server等数据库。Ø         建议专门建立供cognos资料库的实例,表空间用户。Ø         这个库必须是unicode字符集。Ø         如果oracle为8.1.7,则字符集为UTF-8,

yiyunstone的专栏 4689

ibm cognos 10 for linux安装步骤

安装准备 安装环境:redhat6.2 所需安装的文件: cognos BI server 10.1 cognos transformer10.1 oracle 10g客户端 apache(可选) openldap-server 2.4 openldap-client 2.4 openldap-devel 2.4 jdk -1.6-64位 操作系统必须安装中文字库 硬件要求

pengshk 专注于oracle ebs dba跟BI 6622

Cognos安装详解

1安装JDK 注意:安装JDK时使用root用户进行安装 安装步骤: 创建目录 #mkdir -p /usr/java 将jdk目录中内容复制到/usr/java目录中 #cp –fr /jdk-1.7**** /usr/java 修改Jdk目录下可文件执行权限 chmod +x * 执行安装 rpm -ivh jdk-7u7-linux-x64.rpm Preparing...

m0_37253968的博客 2973

Cognos安装

安装前准备 需要安装oracle数据库,作为Cognos的内容库 注:oracle字符编码必须为utf-8,否则会导致Cognos不能启动 组件准备 安装 1、安装IBM Cognos Busniess Intelligence Server      1)在文件夹中找到issetup.exe      2)进入安装界面,选择默认中文      3)同意

爱笑的冷眸 783
上一篇: java socket编程
下一篇: Cognos之操作小技巧
junli0310
博客等级 码龄22年 74粉丝 14原创
评论 2
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值