SQL SERVER还原数据库时"试图扩大物理文件时,MODIFY FILE 遇到操作系统错误 112(磁盘空间不足)"错误处理

开发者福利!热门AI工具限免费用 购周边即赠Coding Plan Lite,Claude Code、Cursor等20+工具畅享,效率翻倍! 阅读详情

现象

在备用机上还原数据库备份时报错

Microsoft SQL-DMO (ODBC SQLState: 42000) 试图扩大物理文件时,MODIFY FILE
遇到操作系统错误 112(磁盘空间不足)。 未能创建一个或多个文件。请考虑使用 WITH MOVE 选项来标识有效位置。 RESTORE
DATABASE 操作异常终止。

原因

但是磁盘空间明明很充足,经过分析,原因如下,备用机对于还原数据的分区文件系统为FAT32,FAT32不支持超过4GB的文件,而还原后的数据库文件已经6个G了。

处理

转换文件系统

针对磁盘空间充足、恢复后单个文件超过4GB、文件系统为FAT32的情况,可以把文件系统转换为NTFS

convert d: /fs:ntfs

改变备份还原的位置

你可以用下面的语句查询还原的数据库有多少个文件,这些文件有多大,还原后文件会放到那个磁盘上

restore filelistonly from disk='f:\20170113.bak'

如果你要把数据文件放到其他空间足够的磁盘上,使用 move 选项来改变还原后的文件位置,示例

restore database dbname from disk='f:\20170113.bak'
with move '逻辑文件名' to 'd:\DBnew.mdf'
--逻辑文件名可以用restore filelistonly 查询,d:\DBnew.mdf是逻辑文件名还原后的位置及文件名
LTE信令流程及业务流程 eNB返回E-RAB建立响应消息,E-RAB建立列表信息中包含成功建立的承载信息,E-RAB建立失败列表消息中包含没有成功建立的承载消息。3)当下行数据达到,网络侧先对UE进行寻呼,随后UE发起随机接入过程,并发起service request过程。用户面:S-GW向eNB发送承载建立请求,包含(IMSI, QoS, TFT, TEID, LBI等)控制面:MME向eNB发送E-RAB建立请求,包含E-RAB ID,QoS,S-GW TEID。3)在S1接口上建立S1承载,在Uu接口上建立数据无线承载。 阅读详情

相关推荐

Unity游戏开发客户端C#基础

初级Unity客户端开发工程师 面经 之 C#篇

Sea3752的博客 2万+

SQL Server数据库修改文件命令执行报错:MODIFY FILE 失败。文件 'DBName' 不存在

SQL Server数据库修改文件命令执行报错:MODIFY FILE 失败。文件 ‘DBName’ 不存在。 最近在迁移SQL Server数据库文件,需要执行MODIFY FILE文件命令以修改文件路径: ALTER DATABASE DBName MODIFY FILE(NAME = DBName, FILENAME = N’E:\MyDBPath\DBName.mdf’); 遇到如下...

heng_z的博客 5205

PyQt5数据库开发3 6 QSqlQuery完整实操案例【图文详解】

PyQt5数据库开发3 6.1 QSqlQuery实操案例【多图详解】,本文有点长,主要每一个步骤都有对应的图文教程!!!

qq_53317005的博客 2943

SQL解决MODIFY FILE 失败。文件 '*******'不存在

USE test GO ALTER DATABASE test MODIFY FILE ( NAME='D:\XP\SQLDB\test.mdf', SIZE=20MB ) 问题是:(MODIFY FILE 失败。文件 'D:\XP\SQLDB\test.mdf' 不存在。)   解决: USE test GO ALTER DATABASE test MODIFY

OPK625153475的专栏 5928

尝试扩展物理文件MODIFY FILE 遇到操作系统错误

解决办法就是把FAT32的文件系统转化为NTFS的FAT32转NTFS的方法:不需要格式化,运行:输入命令convert c:/fs:ntfs其中,c为盘符只要这样就可以把文件系统重FAT32转NTFS了!...

Devilhand 1347

SQL数据库还原出现错误112(磁盘空间不足)的解决办法

还原数据库,遇到操作系统错误112磁盘空间不足)。 [img]F:\QQ截图未命名.jpg[/img] 可能备份日志文件太大,所以硬盘放不下 清空日志 DUMP TRANSACTION 库名 WITH NO_LOG 1、你的SQL Server版本,个人版有2GB限制。 2、检查磁盘的文件格式,如果是FAT32,转换为NTFS格式。...

jc_dreaming2的博客 4686

SQL SERVER还原数据库试图扩大物理文件MODIFY FILE 遇到操作系统错误 112(磁盘空间不足)错误处理

现象 在备用机上还原数据库备份报错 Microsoft SQL-DMO (ODBC SQLState: 42000) 试图扩大物理文件MODIFY FILE 遇到操作系统错误 112(磁盘空间不足)。 未能创建一个或多个文件。请考虑使用 WITH MOVE 选项来标识有效位置。 RESTORE DATABASE 操作异常终止。 原因 但是磁盘空间明明很充足,经过分析,原因如下,备用机对于还原数据的分区文件系统为FAT32,FAT32不支持超过4GB的文件,而还原后的数据库文件已经6个G了。 处理 转换

zy835859234的博客 1327

sqlserver 数据库的问题解决

前言 项目需要用到sqlserver数据库,较mysql数据库有很多不同,这里记录一下遇到的问题。 一、问题如下 1.开启sqlserver扩展报错 描述:可以肯定的是扩展和版本没有任何问题(因为php环境是从另一个服务器直接拷贝过来的),其他扩展均可正常加载。网上各种说法,有说扩展要写绝对路径,这些在我这都没有用。 PHP Warning: PHP Startup: Unable to load dynamic library ‘D:\php\ext\php_pdo_sqlsrv_74_ts_

qq673675158的博客 490

数据库数据恢复】SQL Server数据库磁盘空间不足的数据恢复案例

数据库数据恢复环境: 某品牌服务器存储有2组raid,一组raid1(2块硬盘),一组raid5(5块硬盘); 存放有SqlServer数据库数据库故障: 存放SqlServer数据库的分区由于数据量增加而导致原来划分的空间不足,管理员在另外一个分区中生成了一个.ndf文件并将数据库路径指向这个分区继续使用,一段间后数据库出现故障报错,提示连接失效,SqlServer数据库无法附加查询。管理员于是进行尝试性数据恢复操作没有成功恢复数据,于是联系我们数据恢复中心进行数据恢复。...

beiya123的博客 1865

试图扩大物理文件MODIFY FILE 遇到操作系统错误 112(磁盘空间不足

试图扩大物理文件MODIFY FILE 遇到操作系统错误 112(磁盘空间不足) 我在还原一个10G的数据库候出现了一个错误:“试图扩大物理文件modify file遇到操作系统错误112磁盘空间不足)” 解决办法如下:先看看你的磁盘格式是不是FAT32的,查看方法是鼠标右击属性就可以看到了, 如果是FAT32的,在运行中输入命令:convert C:/fs:ntfs 就行

meilanhaohe的专栏 3593

试图扩大物理文件MODIFY FILE 遇到操作系统错误112(磁盘空间不足)

< DOCTYPE html PUBLIC -WCDTD XHTML StrictEN httpwwwworgTRxhtmlDTDxhtml-strictdtd> 试图扩大物理文件MODIFY FILE遇到操作系统错误112(磁盘空间不足)。 不少朋友在还原数据库候会遇到"在数据还原候出现"试图扩大物理文件MODIFY FIL...

weixin_34247155的博客 676

文件失败 ((null)) | 磁盘空间不足(112)_Kubernetes 最佳实践:处理容器数据磁盘被写满...

容器数据磁盘被写满造成的危害: 不能创建 Pod (一直 ContainerCreating) 不能删除 Pod (一直 Terminating) 无法 exec 到容器判断是否被写满:容器数据目录大多会单独挂数据盘,路径一般是 /var/lib/docker,也可能是 /data/docker 或 /opt/docker,取决于节点被添加的配置:可通过 docker info 确定:$ doc...

weixin_42509398的博客 8002

文件失败 ((null)) | 磁盘空间不足(112)_空三分层?空三失败?POS问题?| CC常见问题解决方法汇总...

ContextCapture Center软件作为倾斜摄影航测业内使用最广泛的软件之一,在使用过程中会遇到各种各样的问题。为此,我们整理了CC工作中遇到的常见问题与解决方法,分为数据整理、空三、建模三大部分,供大家参考。一、数 据 整 理1影像与pos数量不一致Pos与影像的关系:飞机飞行过程中每曝光一次GPS记录一个位置信息(pos)即pos跟影像为一一对应关系。问题一:pos数...

weixin_31650287的博客 8716
上一篇: MS sqlserver 数据库异地备份到其他计算机(xp_cmdshell)
下一篇: Requests 之Max retries exceeded with url[Errno 10054]错误新解
mighty13
博客等级 码龄23年 727粉丝 438原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值