Cinder volume 挂载

开发者福利!热门AI工具限时免费用 购周边即赠Coding Plan Lite,Claude Code、Cursor等20+工具畅享,效率翻倍! 阅读详情

GNU/Linux

From a shell issue the lsblk command, this will list the block devices you can use:

admin@mariadb:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
vda    253:0    0   160G  0 disk
└─vda1 253:1    0   160G  0 part /
vdb    253:16   0   9.8T  0 disk

The device /dev/vda is the root disk of your system. It has one partition called /dev/vda1 filling all the space. Then you can see /dev/vdb which is the volume you just attached.

In order to be able to use it you need to format it and mount it somewhere.
This is easily done with:

admin@mariadb:~$ sudo mkfs.ext4 /dev/vdb
Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

admin@mariadb:~$ sudo mkdir /storage

admin@mariadb:~$ sudo mount /dev/vdb /storage

admin@mariadb:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/vda1       158G  1.1G  150G   1% /
/dev/vdb        9.7T   38M  9.3T   1% /strorage

You can now store your files on the directory /storage.

对已经使用的目录使用软链接的方式扩容:

cd /home

mv k8s /storage/

ln -s /storage/k8s /home/k8s

这样就建立了一个软连接

cd /home/k8s 实际上进入的是/storage/k8s

cinder创建的volume通过iscsi协议挂载到instance流程分析 输入命令:nova volume-attache volume-id server-id 一、cinder-api   1、POST一个http消息,body是connection初始化(initialized_connection)的相关信息,192.168.232.12是要挂载虚机所在计算节点的IP地址,那么可以看出初始化信息包含了计算节点的相关信息   上图是初始化成功之前,进行的 阅读详情

相关推荐

openstack attach volume过程详解

用了很长时间的openstack,回过头来,回想一些细节问题,可能还是没有彻底理解。比如: cinder中有attach volume的API nova中也有volulme attachment create的API 那么两者有什么区别的? 下面详细介绍。 openstack 给节点挂载云盘有两种方式: 1)nova boot时候,添加 --block-devi

sufetion的专栏 5091

cinder 卷none连接处理办法

作者:吴业亮 cinder的卷在删除的时候经常因为消息队列和数据库问题导致删除失败,使卷的状态为none。在dashboard上刷新会跳出找不到卷信息。解决办法如下: 导出数据库,以防误操作 mysqldump -uroot -p -B --all-databases | gzip > all.sql.gz 修改数据表 MariaDB [cinder]&am...

塔尖草的博客 607

Openstack Cinder入门初探

Cinder背景:        Openstack从folsom版本开始,出现了一个全新的

blueskywhitecloud11的专栏 1697

openstack 卸载/挂载 系统卷

调用 nova    volume-detach      可以卸载云主机已挂载的云硬盘 但是如过卸载云主机的系统卷时会报如下错误: ERROR (Forbidden): Can't detach root device volume (HTTP 403) 如果想要卸载掉系统卷,可按如下步骤操作: 1.cinder数据库中更改系统卷的mountpoint (系统卷的默认挂载

Nicholas的专栏 8309

Cinder volume服务启动以及创建挂载过程代码走读

cinder-volume的task_flows 中提取volume的spec相关信息,通知volume创建,开始创建volume云盘,因为基于镜像创建系统盘,所以执行_create_from_image函数,调用rbd driver clone_image,同时更新volume_glance_metadata表。筛选根据az,容量,特性等filter筛选合适的backend,并更新volume backend信息,最后调用cinde-volume的rpc_api create_volume

一名运维开发工程师的日常记录 1113

openstack运维实战系列(三)之cinder磁盘挂载

1. 概述openstack的cinder项目负责volume的服务,即虚拟机的外存储,cinder作为管理存储的工具,可以支持LVM,glusterfs,ceph,sleepdog等开源的存储方案,同时也提供了对HP,IBM,huawei等商业存储的支持,配置完cinder之后,即可对虚拟机分配存储空间,如下给虚拟机分配cinder存储空间为例,讲述cinder的...

weixin_33695450的博客 1015

挂载Cinder Volume的实例无法动态迁移排错

现象:挂载Cinder Volume的实例无法动态迁移 [root@node-5 nova]# tail -f compute.log 2016-01-13 16:36:12.870 18762 ERROR nova.virt.libvirt.driver [-] [instance: 9d3e4665-801e-44bd-b93a-82951102cc22] Live Mi...

diaogeng2629的博客 204

Unable to attach cinder volume to VM

在测试openstack中的volume服务时把lvm挂载到虚拟机实例时失败 以下是计算节点nova-compute.log 的错误日志: 2012-07-24 14:33:08 TRACE nova.rpc.amqp ProcessExecutionError: Unexpected error while running command. 2012-07-24 14:33:08 TRAC

当你感觉累的时候,证明你正在走上坡路! 2922

Attach Volume 操作 openstack

上一节我们创建了 volume,本节讨论如何将 volume attach 到 Instance,今天是第一部分。 Volume 的最主要用途是作为虚拟硬盘提供给 instance 使用。Volume 是通过 Attach 操作挂载到 instance 上的。本节我们就来详细讨论 Cinder 是如何实现 Attach 的。 上一节我们成功创建了基于 LVM provider 的 volume。每个 volume 实际上是存储节点上 VG 中的一个 LV。 那么问题来了:存储节点上本地的 ...

qq_42533216的博客 629

openstack_cinder里面的volume的简单解析

Openstack云硬盘的使用: $ nova volume-attach 云主机名称 volume_id 例子附加 09e3743e-192a-4ada-b8ee-d35352fa65c4卷到public-instance 实例:nova volume-attach public-instance 09e3743e-192a-4ada-b8ee-d35352fa65c4+———-+——————

CloudXli的博客 2987

cinder挂载卷流程分析

cinder挂载卷流程分析,存储类型以lvm+iscsi的方式为分析基础cinder侧主要调用了三个接口1)reserve_volume: 把volume的状态改为attaching,阻止其它节点执行挂载操作。2)initialize_connection: 这个方法负责构建和返回nova调用者需要的所有信息。返回的信息中包括CHAP credential, target-iqn 和lun 信息...

weixin_30242907的博客 487

Cinder AZ 与 Nova AZ 的同步问题

问题

烟云的计算 2764

OpenStack学习笔记(四)Cinder组件

Cinder主要架构 与nova类似,cinder也采用的是松散的架构理念,由cinder-api统一管理外部对cinder的调用,cinder-scheduler负责调度合适的节点去构建volume存储。volume-provider通过driver负责具体的存储空间,然后cinder内部依旧通过消息队列queue沟通,解耦各子服务支持异步调用。 cinder-shedule...

TinaSprunt的开发笔记 1991

重启物理机过后Cinder volume无法再挂载的简便解决方法

2019独角兽企业重金招聘Python工程师标准>>> ...

weixin_34161083的博客 274

linux 后端存储,配置NFS网络存储作为cinder的后端存储

安装cinder和nfsyum install -y openstack-cinderyum install cifs-utils在controller节点配置nfs[[emailprotected] ~]# mkdir -p /data/nfs #创建一个共享挂载资源的目录[[emailprotected] ~]# cat /etc/exports/data/nfs *(rw,sync,r...

weixin_28278377的博客 398

Attach Volume 操作(Part II) - 每天5分钟玩转 OpenStack(54)

Attach Volume 操作(Part II) - 每天5分钟玩转 OpenStack(54) 上一节我们讨论了 attach volume 操作中 cinder-api 的工作,本节讨论 cinder-volume 和 nova-compute 如何将 volume attach 到 Instance。 cinder-volume 初始化 volume 的连接 cinder-volume 接收到 initialize_connection 消息后,会通过 tgt 创建 target,

qq_42533216的博客 421

Cinder服务的基本使用

OpenStack早期版本是使用nova-volume为云平台提供持久性块存储服务。从Folsom版本后,就把作为Nova组成部分的nova-volume分离出来,形成了独立的Cinder组件。Cinder本身并不直接提供块存储设备实际的管理和服务,而是在虚拟机和具体的存储设备之间引入一个抽象的“逻辑存储卷”。

XiaoXinYAYAYA的博客 1395

Cinder - 读取glusterfs_shares_config代码

cinder创建glusterfsvolume的函数 vim/usr/lib/python2.7/site-packages/cinder/volume/drivers/glusterfs.py @utils.synchronized('glusterfs',external=False) defcreate_volume(self,volume): ...

weixin_34380296的博客 127

OpenStack Grizzly实例重启之后cinder-volume服务无法启动的解决办法

问题描述:Cinder组件装在Controller节点,节点发生故障重启后,发现挂载了volumn的实例无法启动,并且无法创建及挂载定的volume,查看cinder-volume服务,处于stop状态,执行启动命令发现无法启动,错误日志如下: 2013-12-19 14:44:33 INFO [cinder.service] Starting 1 workers 2013-12-19

VF@CSDN 2638
上一篇: haproxy
下一篇: kubernetes heapster influxdb
NKCCDD
博客等级 码龄11年 7粉丝 49原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值