centOS5.6 下的nginx+mysql+php+php-fpm安装与配置

开发者福利!热门AI工具限时免费用 购周边即赠Coding Plan Lite,Claude Code、Cursor等20+工具畅享,效率翻倍! 阅读详情

nginx安装:我是直接按照官网上的方法安装
一、访问nginx官网:http://nginx.com/ (目前稳定版是nginx-1.2.2 )。进入下载页面(http://nginx.org/en/download.html),这个页面介绍的怎么安装nginx。对于centos的用户,nginx官方给出了rpm包源,下载后用yum可安装,也可以直接下载源码安装。在此我是用的是rpm源的安装方法。
二、rpm -ivh http://nginx.org/packages/centos/5/noarch/RPMS/nginx-release-centos-5-0.el5.ngx.noarch.rpm
命令来下载rpm包
三、yum install nginx

四、设置开机自启,启动nginx,关闭nginx服务

>chkconfig nginx on

>/etc/init.d/nginx stop

>/etc/init.d/nginx start

五、nginx的配置文件目录都在/etc/nginx下(包括fastcgi的配置,下面要用到)。

六、测试:直接在浏览器中输入http://192.168.1.220(你机器的ip地址)访问

如果出现,那么恭喜你,nginx安装成功!

Welcome to nginx!



mysql安装:确保先于php安装,因为这个才能保证php正确加载mysql扩展
一、yum install mysql mysql-server php-mysql
二、查看mysql安装情况。
>mysql -u root
如果能进入,那么mysql安装成功。
设置root密码
>mysql -u root password mypassword

(如果是源码和rmp安装,官方下载地址:http://mysql.mirrors.hoobly.com/Downloads/ 

mysql的版本众多,对于我这个beginner来说有点为难啊!)


关于mysql的安装,如果yum来安装,centos的默认源是5.0的,版本太老了。所以研究了怎么从官方获取最新rpm源来安装。

获取源:

wget http://www.mysql.com/get/Downloads/MySQL-5.5/MySQL-server-5.5.25a-1.rhel5.x86_64.rpm/from/http://cdn.mysql.com/--------》mysql的服务端
wget http://www.mysql.com/get/Downloads/MySQL-5.5/MySQL-client-5.5.25a-1.rhel5.x86_64.rpm/from/http://cdn.mysql.com/---------》mysql的客户端

wget http://www.mysql.com/get/Downloads/MySQL-5.5/MySQL-devel-5.5.25a-1.rhel5.x86_64.rpm/from/http://cdn.mysql.com/---------》mysql的开发包,要支持php,必须安装此包,不然会出现找不到mysql.h,客户端没有绑定错误

rpm -ivh MySQL-server-5.5.25a-1.rhel5.x86_64.rpm MySQL-client-5.5.25a-1.rhel5.x86_64.rpm MySQL-devel-5.5.25a-1.rhel5.x86_64.rpm

 yum install MySQL-server-5.5.25a-1.rhel5.x86_64.rpm MySQL-client-5.5.25a-1.rhel5.x86_64.rpm MySQL-devel-5.5.25a-1.rhel5.x86_64.rpm

安装php和php-fpm

一、php的版本选择以前的稳定版5.3.14。由于php5.3.x直接绑定php-fpm,所以php-fpm是没有php5.3.x的包。

二、通过源码安装php5.3.14。

wget http://cn.php.net/get/php-5.3.14.tar.bz2/from/this/mirror

tar -xvjf php-5.3.14

cd php-5.3.14

下载源码

三、安装(php源码安装的话,其参数会非常多。具体看你加载那些扩展)

> ./configure -enable-fpm --with-mysql=/usr/bin/mysql --with-curl --with-zlib_dir=/usr/lib64 --with-gd --with-mysqli

( -enable-fpm 开启php-fpm,cgi模式

--with-mysql=/usr/bin/mysql   /usr/bin/mysql是你的mysql客户端的地址

--with-mysqli 加载mysqli扩展

--with-curl加载curl扩展

--with-zlib_dir=/usr/lib64这个暂时不知道什么意思,但是不加上会出现:configure error:Try adding --with-zlib_dir=<DIR>……错误

--with-gd加载gd扩展

--with-mcrypt

--with-mhash

--with-mbstring

>make

>make install

四、配置nginx来支持php

找到/etc/nginx/conf.d/default.conf,打开编辑它

>vi /etc/nginx/conf.d/default.conf

去掉下面部分的注释用于支持 php 脚本:

    location ~ \.php$ {
        root           html;
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_param  SCRIPT_FILENAME  /usr/share/nginx/html$fastcgi_script_name;
        include        /etc/nginx/fastcgi_params;
    }

fastcgi_param  SCRIPT_FILENAME  /usr/share/nginx/html$fastcgi_script_name; /usr/share/nginx/html指你的网站目录

include        /etc/nginx/fastcgi_params; 要确保找对文件地址


重启nginx服务

>/etc/init.d/nginx stop

>/etc/init.d/nginx start

启动php-fpm

>/usr/local/sbin/php-fpm

五、测试php文件

/usr/share/nginx/html目录下创建phpinfo.php文件

>vi phpinfo.php

其内容:

<?php

phpinfo();

六、测试

然后在浏览器中输入http://(你机器的ip地址)/phpinfo.php,如果出一个php的特色标志页面,就说明安装成功了

七、其他问题

error: mysql configure failed.问题

说实话,加载mysql扩展是废了我一番功夫。因为每次编译的时候都会error: mysql configure failed.这个问题。我看了一个config.log文件,但由于本人能力有限,没看出什么名堂。所以就借助Google找答案。结构是在64位的centos的mysql官方rpm都会有这个问题。(查看你的系统的版本:使用uname -a,如果出现   Linux  2.6.18-238.el5 #1 SMP Thu Jan 13 15:51:15 EST 2011 x86_64 x86_64 x86_64 GNU/Linux 就说明是64位。而i386是32位的

解决方法:使用下面命令后,再重新编译php

ln -s /usr/lib64/mysql/ /usr/local/lib/mysql
ln -s /usr/include/mysql/ /usr/local/include/mysql

八、php-fpm重启

php5.3内置了fpm,那么fpm进程就只能用信号控制

>locate php-fpm.pid

cat /usr/local/php/var/run/php-fpm.pid

 >kill -USR2 `cat /usr/local/php/var/run/php-fpm.pid`

>ps aux|grep php-fpm

九、安装phpmyadmin

到phpmyadmin官网上去下载最新的包(http://www.phpmyadmin.net/home_page/downloads.php

cd /usr/share/nginx/html----->你的nginx网站目录

wget http://sourceforge.net/projects/phpmyadmin/files/phpMyAdmin/3.5.2/phpMyAdmin-3.5.2-all-languages.tar.bz2

tar -xvjf phpMyAdmin-3.5.2-all-languages.tar.bz2

cp phpMyAdmin-3.5.2-all-languages phpmyadmin

cp config.sample.inc.php config.inc.php----> 一般这部不需要

十、加载php扩展

例如加载zip扩展

cd php-5.3.14(php的源码目录)

cd ext/zip(扩展对应的源码目录)

/usr/local/bin/phpize(用phpize扩展挂载工具)

 ./configure --with-php-config=/usr/local/bin/php-config 

make

make install

如果按装成功,会返回此扩展的安装目录(如/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/

vi /etc/php.ini

在php.ini文件中加入

extension=/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/zip.so

重启php-fpm

(期间我安装扩展又出现来问题,冥冥修改了php.ini文件(此处的php.ini的路径是/etc/php.ini)但phpinfo()输出就是没有加载上。所有的编译和安装都没有报错。我也仔细查看了zip.so的路径也是正确。思索了一会突然看见phpinfo()输出信息中关于php.ini的描述是这样的

Configuration File (php.ini) Path /usr/local/lib
Loaded Configuration File (none)
居然路径是在/usr/local/lib下,进去却没发现php.ini文件。原来我在源码安装时没有配置--prefix,所以php.ini的默认路径是 /usr/local/lib。这时需要把/etc/php.ini考到/usr/local/lib下。

此外/etc/php.ini中的extension_dir的路径是/usr/lib64/php/modules

extension_dir=/usr/lib64/php/modules

modules所以最好把zip.so拷贝到/usr/lib64/php/modules下,然后在php.ini中加一句

extension=zip.so

然后重启php-fpm,就可以看到加载的扩展。

十一、安装过程中遇到的问题

1.安装php中的mcrypt出问题:mcrypt.h not found. Please reinstall libmcrypt

解决方法:

wget ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/attic/libmcrypt/libmcrypt-2.5.7.tar.gz 
 tar -zxvf libmcrypt-2.5.7.tar.gz ----->ps: 解压

 cd libmcrypt-2.5.7 
 mkdir -p /usr/local/libmcrytp 
 ./configure prefix=/usr/local/
 make
 make install 

假设安装在/usr/local/,在configure PHP的时候加上--with-mcrypt=/usr/local/lib

2.

参看资料:

1.php-fpm重启:http://blog.sina.com.cn/s/blog_6fb90ed30100u06p.html

2.ubuntu和linux上安装lnmp:http://www.cslog.cn/Content/ubuntu-10-04-nginx-0-8-52-php-fpm-5-3-3-apc-mysql-i/http://blog.csdn.net/21aspnet/article/details/6581724

3.error: mysql configure failed问题:http://blog.csdn.net/wlx3351/article/details/5938964http://mylinux.5d6d.net/thread-856-1-1.html

4.erro:mysql configure failed问题的另一种解决方法:http://www.bitbi.biz/%E7%BC%96%E8%AF%91%E5%AE%89%E8%A3%85php%E5%87%BA%E7%8E%B0configureerrormysql-configure-failed%E8%A7%A3%E5%86%B3-115/




Linux服务器CentOs7部署Nginx1.21+Mysql5.7+php5.6 记录php项目部署CentOs7服务器,使用nginx+mysql 阅读详情

相关推荐

LIS2DH12加速度计实战:寄存器配置、低功耗运动检测应用

MEMS加速度计是物联网节点、可穿戴设备工业状态监测中感知运动的核心器件,其工作原理基于微机械结构将加速度转化为电信号,再通过数字接口输出。在工程实践中,正确配置量程、采样率、FIFO和中断引脚,能大幅提升系统实时性并降低功耗。ST的LIS2DH12作为一款2x2x1mm的数字三轴加速度计,支持I2C/SPI接口、内置32级FIFO和可编程阈值中断,非常适合STM32等主控协同实现运动控制、姿态识别和振动检测。例如在塑料水管泄漏检测中,利用高ODR采集振动波形;在可穿戴设备中,通过低功耗模式6D方向检

weixin_33906657的博客 363

centos7 nginx环境下安装php5.6

1.删除旧包 yum remove php.x86_64 php-cli.x86_64 php-common.x86_64 php-gd.x86_64 php-ldap.x86_64 php-mbstring.x86_64 php-mcrypt.x86_64 php-mysql.x86_64 php-pdo.x86_64 2.配置epel源 yum install -y epel-release wget -O /etc/yum.repos.d/epel.repo http://mirrors.

三思 875

解决php-fpm.service not found问题的办法

前言 本文给大家详细介绍了解决php-fpm.service not found问题的相关内容,文中介绍的非常详细,下面来一起看看详细的介绍: 环境介绍 环境:ubuntu 16.04 64 php 版本:php-7.1.4 发现问题 正常编译安装 php 按照以前流程,把 init.d.php-fpm 往 /etc/init.d/php-fpm 拷贝 然后准备执行 service php-fpm start 时出错了 错误如下 Failed to start php-fpm.service: Unit php-fpm.service not found. 提示 php-fpm.servi

PHP5.6php-fpm配置、启动、关闭和重启

该文主要讲述:如何配置php-fpm、常见报错解决方法和php-fpm的启动、关闭和重启。 LNMP环境中的nginx是不支持php的,需要通过fastcgi插件来处理有关php的请求。而php需要php-fpm这个组件提供该功能。在php5.3.3以前的版本php-fpm是以一个补丁包的形式存在的,而php5.3.3以后只需在编译安装时使用–enable-fpm加载该模块即可,无需另行安装...

Field_Yang的博客 5万+

nginx环境下配置支持php5.6nginx+PHP

该文主要讲述在nginx环境下如何配置支持php5.6,主要分为三部分:配置安装PHP5.6.25配置php-fpm组件,配置nginx支持PHP(请自行编译安装nginx)  1、配置安装PHP5.6.25 [root@localhost share]# cp php-5.6.25.tar.gz/usr/local [root@localhost share]# cd /usr/loca...

Field_Yang的博客 1万+

源支付Nginx + PHP 7.2 + Mysql 5.6,实测可用,供大家学习研究参考!

源支付 推荐环境Nginx + PHP 7.2 + Mysql 5.6 上传源码到根目录 设置网站运行目录public、随后设置伪静态为ThinkPHP 打开域名就可以到安装界面了 注意:搭建好之后必须设置计划任务! 具体如下 宝塔计划任务——Shell脚本,名称随便-执行周期设置一分钟,脚本内容如下,记得改好你自己域名!!! #!/bin/bash step=10 #间隔的秒数,不能大于60 for (( i = 0; i < 60; i=(i+step) )); do

centos5.6配置nginx php mysql,centos 5.6安装nginx mysql php(php-fpm)

Centos 默认官方源中没有nginxphp-fpm 所以必须添加第三方源,不然就只能自己编译了。启用CENTOS的额加包。如果不安装,可能会出现不能安装NGINX的问题添加[CentALT]源在/etc/yum.repos.d 目下创建 alt.ru.repo 文件内容如下:[CentALT]name=CentALT Packages for Enterprise Linux 5 - $...

weixin_39950772的博客 133

php5.6 开启fpm,php5.6源码安装php-fpm配置

LNMP环境的搭建中,现在只有php没有源码安装过。这篇文章就把这个介绍下。注意本篇文章使用的centos 6.5 64bit。登陆centos下载php5.6安装包。php的软件包可以去国内的souhu镜像站点去下载。wgethttp://mirrors.sohu.com/php/php-5.6.2.tar.gz在安装之前,我们需要安装php5.6编译时所依赖的软件包。如下:yum -y i...

weixin_42463165的博客 645

php5.6 mysql nginx_centos7 nginx+php5.6+mysql安装配置

安装配置php 56安装php配置写在 php.ini,可在phpinfo()中查看//查找已安装yum list installed | grep php// php卸载yum -y remove php56*yum remove httpd* php*可用的资源:centos 安装php56+nginxnginx + php-fpmnginx安装sudo rpm -Uvh http://...

weixin_32950759的博客 251

centos7 yum 安装配置nginx+php7.3+php-fpm+mysql5.6

安装配置LNMP 一、安装配置nginx服务 获取比较新的nginx的yum源数据 rpm -Uvh http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ngx.noar...

chipiaobai6529的博客 3671

centos 安装 nginx + php

一 、 安装nginx 这个先不讲,后面补上,而且网络上有很多安装nginx的,也没什么难点,这次主要是安装PHP。 二、安装php #下载: wget http://bg2.php.net/distributions/php-5.6.7.tar.gz #解压 tar zxvf php-5.6.7.tar.gz #编译 ./configure --prefix=/usr...

qq_38314112的博客 378

CentOS7安装配置LEMP(Nginx/PHP-FPM 5.6/MySQL 5.5)网站环境过程

一般大型的网站建站环境都会采用Nginx系统环境架构,相对而言比Apache承受承载的线程和压力更大,不过对于一般的博客、网站来说,Apache环境也足够使用。在之前的相关文章中,无论是LNMP一键安装包、还是LEMP一键包、以及AMH等WEB面板,都是采用NGINX搭建的网站环境。 在这篇文章中,老左整理一篇基于最新的CentOS7系统,搭建和应用Nginx/PHP-FPM 5.6/M

csdn265的博客 944

php56wmysql_Centos6.9下 yum 安装 nginx1.10 + mysql5.6 + php5.6(示例代码)

一、准备工作1、检查selinux是否为关闭状态,不为disable需要改为disable。SELINUX=disabled不为disabled 的话,则修改为 SELINUX=disabled。2、检查环境下有没有安装过低版本的rpm -qa|grep mysqlmysql-libs-5.1.73-8.el6_8.x86_64rpm -qa|grep nginxrpm -qa|grep p...

weixin_31408789的博客 125

centos7 安装 php7.3  mysql5.6   nginx1.6

centos7 安装 php7.3 mysql5.6 nginx1.6 第一步 安装nginx yum -y install epel-release lrzsz zip unzip wget tree git dpkg pcre pcre-devel openssl openssl-devel gd-devel zlib-devel gcc wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/rep...

eureka_eureka的专栏 231

centos php mysql 5.6 安装_centos7安装nginxphp5.5mysql5.6

一、nginx1、安装yum install nginx2、启动systemctl start nginx关闭:systemctl stop nginx 重启:systemctl restart nginx 检查状态:systemctl status nginx3、测试浏览器直接访问http://ip,应该会看到以下界面:4、支持php打开/etc/nginx/nginx.conf在server_...

weixin_42652674的博客 314

centos 编译安装 php 5.5,基于CentOS6.5环境之下的LNMP之编译安装PHP5.5.30

基于CentOS6.5环境之下的LNMP之编译安装PHP5.5.30发布时间:2020-04-26 21:34:55来源:51CTO阅读:459作者:arliang785LNMP之编译安装PHP5.5.301、编译前操作:1.1、netstat-tulnp|egrep"80|3306"tcp000.0.0.0:800.0.0...

weixin_26706567的博客 213

【推荐】CentOS安装PHP-5.6.4+扩展安装+安全配置+性能配置

注:以下所有操作均在CentOS 6.5 x86_64位系统下完成。 #准备工作# 前段时间PHP官方发布了一个重要的安全升级公告,修复了两个unserialize函数的严重漏洞,目前受影响的版本有: <5.4.36 <5.5.20 <5.6.4 这里我们直接下载5.6.4的版本进行安装配置,并且在这之前需要先把MySQL和Apache已经...

weixin_30951389的博客 276

烂泥:php5.6源码安装php-fpm配置nginx集成

2019独角兽企业重金招聘Python工程师标准>>> ...

weixin_34082695的博客 92

CentOS 7配置LNMP开发环境及配置文件管理[Mysql数据库]

Nginx主机配置(设置php-fpm) 编辑/etc/nginx/conf.d/default.conf配置文件,并重启。 server {    listen       80;    server_name  localhost;    #charset koi8-r;    #access_log /var/log/nginx/log/host.

qq_37248529的博客 416
上一篇: 关于php的set_time_limit和进程结束的问题
下一篇: php的crc32的陷阱
miniDan__
博客等级 码龄18年 8粉丝 23原创
评论 1
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值