Weblogic自动部署与手动部署 异常记录与解决方法

开发者福利!热门AI工具限时免费用 购周边即赠Coding Plan Lite,Claude Code、Cursor等20+工具畅享,效率翻倍! 阅读详情

weblogic在控制台部署项目时提示:
The application ‘mycim2Ejb’ was autodeployed and may only be redeployed by touching REDEPLOY file in the domain autodeploy directory for respected application.
在这里插入图片描述
1.排查思路:
检查项目是否属于自动部署的目录:domain_home/autodeploy
属于autodeploy则不能手动部署,想要变更为手动部署,则新建一个stage目录,将项目放在stage目录下,重新install,重新deploy即可访问。
重新部署后的目录:domain_home/stage
在这里插入图片描述
2.手动部署时,自动部署的项目仍然存在,
导致报错:[EJB:011055]Error deploying the EJB ‘AlmSetupManagerSL(Application: mycim2Ejb, EJBComponent: almEjb2.0.jar)’, the JNDI name ‘statelessSession.AlmSetupManager’ is already in use. You must set a different JNDI name in the weblogic-ejb-jar.xml deployment descriptor or corresponding annotation for this EJB before it can be deployed.
解决思路:
1.删除自动部署项目,保留手动部署项目
2.删除手动部署项目,保留自动部署项目
在这里插入图片描述
1.删除自动部署项目,操作:
去domain_home/config/config.xml文件中查看,将设置为autodeploy路径下的项目删除,
更改配置文件后,重启weblogic服务即可
在这里插入图片描述
2.删除手动部署项目:
在这里插入图片描述
在这里插入图片描述
参考文章:
https://blog.csdn.net/yangschfly/article/details/81216363

weblogic部署CXF系统问题服务端 环境:Weblogic 11g 阅读详情

相关推荐

LSTM模型 轨迹经纬度预测

原始时间序列数据如下所示,我们只取前两列纬度和经度作为输入数据 我们设定用前六个位置信息预测下一个位置,则两个样本的输入输出数据如下所示: 创建LSTM网络训练模型: import numpy as np from keras.layers.core import Dense, Activation, Dropout from keras.layers import LS...

Muzi_Water的博客 2万+

websphere-05 scanJAR unable to open报错

部署war包报错: [19-6-17 16:00:18:917 CST] 000000d7 ecs W com.ibm.ws.ecs.internal.scan.context.impl.ScannerContextImpl scanJAR unable to open input stream for resource freemarker/core/_Java8Impl.class in archive WEB-INF/lib/freemarker-2.3.26-incubatin...

2055

自动驾驶学习笔记——Prescan和Simulink 学习笔记和问题记录(1)】

主要记录一些Prescan/Simulink 联合仿真出现的问题。

ly1336545868的博客 1408

was8.5.5.9项目部署失败,出现mybatis的jar包异常

项目在was8.5.5.0上部署正常,但是换到was8.5.5.9部署的时候报错: W com.ibm.ws.ecs.internal.scan.context.impl.ScannerContextImpl scanJAR unable to open input stream for resource org/apache/ibatis/javassist/tools/rmi/ObjectN...

book 3089

was启动报错:com.ibm.ws.ecs.internal.scan.context.impl.ScannerContextImpl

今天使用was安装应用的时候,启动应用不成功,查看日志, 报错:W com.ibm.ws.ecs.internal.scan.context.impl.ScannerContextImpl 一看,自己还慌的一批。 不管怎么样,bug都得解决。 一开始,我还以为这些class找不到,我查看了一下war包,是有的。 再就去检查一下相关jar包依赖,也没有问题。 百思不得其解。 然后,...

JinKin_OldWang的博客 2417

was环境访问https_WAS问题整理

注意:文章中的WAS版本为8.5.5.9/13/15,spring 2.0.31启动时加载不了jar问题1.1问题描述在WAS 8.5.5.9 上面部署应用出现如下错误com.ibm.ws.ecs.internal.scan.context.impl.ScannerContextImpl scanJAR unanble to open input stre...

weixin_39567870的博客 1536

weblogic 10.3部署失败报出的异常,求解决~~~~~~~~

<br />我是先添加了ear包(部署正常),后来又部署了war包时,但是部署war包不成功,报出了下面的异常,前提是我weblogic的jndi配置经过测试正常,所以,我想请教大家帮我解决问题~谢谢~<br /> <br /> <br /> <br /> <br />Exception: [HTTP:101216]Servlet: "SchedulerCenter" failed to preload on startup in Web application: "SrcWeb-1.0.0.war". j

luo809976897的专栏 1885

记录一次weblogic部署springboot项目

spring boot版本:2.1.0.BUILD-SNAPSHOT weblogic版本: 12.2.1.3.0 数据库 : oracle 12c rac 生产环境上有一套现成的weblogic 12.2.1.2.0 但是项目部署上去以后出现如下异常 weblogic.application.ModuleException: java.lang.IllegalAccessError: tri...

lyl117363的博客 4250

Weblogic--Weblogic部署方式和缓存

参考网址: http://dead-knight.iteye.com/blog/1938882 Weblogic11g部署web应用,有三种方式,非常简单,但是很多新手部署总是出现若干错误,不知道如何解决。下面以白衣大神的springside3应用举例(原因是springside3很有代表性)详细讲解: 1、准备springside3的应用(mini-web、mini-service...

admin87012的博客 600

weblogic 部署问题

以前没在weblogic部署过应用,今天试了下,遇到了很多问题,多数是配置的问题。 具体问题如下:java.lang.ClassCastException: weblogic.xml.jaxp.RegistrySAXParserFactory 异常  和 weblogic.servlet.jsp.CompilationException  异常 网上搜了下,说是xml-apis.jar包冲

花开无声,岁月无痕 995

weblogic服务器自动关闭

问题分享 服务器以前运行没问题,最近出现了weblogic自动关闭的问题,服务器和程序最近也没有动过?    1、查看管理域受管域的相应日志 2、查看运行的程序的日志在出现问题时是否出现大量异常 3、是否在服务器上生成了core文件   你的程序部署在管理域还是受管域上了?总有个地儿,对吧 你看一下你所部署的server所对应的日志   这边没有部署管理域和受管理域,最近越来越...

liushengbaba的专栏 3323

weblogic部署war冲突解决记录

问题描述:应用在tomcat上运行没有问题,在weblogic报错。 原因1 观察日志的最后一行,不要自动换行,异常一般会嵌套很多层,看到最后一层应该就是问题的源头,这次找到的问题原因是org.joda.time.DateTime 包冲突了,解决办法是 在weblogic.xml 中加入 <container-descriptor> <show-ar...

weixin_30600197的博客 440

weblogic 部署错误at weblogic.management.deploy.slave.SlaveDeployer.getApplicationInputStream(SlaveDeployer.java:1882)

前几天部署了一个项目,当时项目名为hena,部署成功也好用,后来因为项目名不准确,将【hena】改为【henan】结果重新启动weblogic是报一下错误:or weblogic.management.DeploymentException: [Deployer:149206]Failed to stage the component null of the application webapps.. java.lang.Throwable: [Deployer:149206]Failed to

anhuixiaozi的专栏 1万+

weblogic安装以及异常解决方法【转】

weblogic安装以及异常解决方法【转】

w36680130的博客 312

WebLogic11g-部署web应用(以Springside3为例)

WebLogic11g-部署web应用(以Springside3为例) Weblogic11g部署web应用,有三种方式,非常简单,但是很多新手部署总是出现若干错误,不知道如何解决。下面以白衣大神的springside3应用举例(原因是springside3很有代表性)详细讲解: 1、准备springside3的应用(mini-web、mini-service),这里我整理为一

BoomJane的专栏 1520

一些关于Linux上的weblogic部署问题

今天部署weblogic的时候纠结了半天,过程是这样的:我先是在一个domain下弄了两个war包的部署,可能因为程序中应用了memerch的缘故,导致其中一个程序部署没有了数据,加载不了了,因为后一个memerch对象会覆盖前一个对象。这样我就想用weblogic的热部署来重起一下两个项目,结果,在weblogic的控制台里,项目部署上没update的显示了,它为灰色,只能点击start和...

iteye_20696的博客 320

weblogic14安装部署及问题

太懒了,稍微说一下直接贴出参考资料供搭建参考使用。最近公司决定废弃tomcat用更高级的weblogic下面是我安装及部署过程中的问题及参考的资料,在这里感谢各位大神的宝贵参考资料。 在此简单说几点: 1、一开始我是用的12版本,最终以失败告终,然后选择最新版本具体原因为未知,安装成功后部署总是失败。 2、注意文件隐藏文件的查看编辑(命令:ll -al)。 3、oraInst.loc、wls.rsp这两个文件未知随便放。使用中会写存放的路径。 4、注意文件的权限我是直接放开所有权限 chmod -R 77

sinat_39512352的博客 2484

weblogic乱码报错解决思路

重定向 url 为 /console/console.portal?mv Webة¼þ.html Web组件.html。11.删除程序,处理程序中的乱码后,重写部署后成功。1.集群备份 weblogic虚拟机快照备份。10.更新,程序部署路径,换新程序,7.尝试启动,新的报错还是显示乱码。2.查看主节点控制台面板状态。4.1查看162.主节点日志。9.点击更新程序,继续报错。

大虾别跑 3887

weblogic java.lang.NoSuchMethodError: javax.persistence.Table.indexes() 排错记录

记录一下项目部署weblogic发生的java.lang.NoSuchMethodError: javax.persistence.Table.indexes()异常。 项目在tomcat中运行正常。部署weblogic12c时,运行报错。 Invocation of init method failed; nested exception is java.lang.NoSuchMethod...

Markix的博客 1455

weblogic部署项目出现的一些问题(持续补充中……)

好吧,weblogic的问题确实……   问题一: org.springframework.beans.factory.BeanDefinitionStoreException: Failed to read candidate component class: URL [zip:E:/weblogic/user_projects/domains/base_domain/servers/Ad

qq_18875541的博客 9320
上一篇: 将Oracle zip安装文件转换成Linux可用的iso镜像
Ego-
博客等级 码龄10年 146粉丝 36原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值