阿里云服务器CentOS 安装配置LAMP服务器(Apache+PHP5+MySQL)

限时加码!20+主流AI编程工具免费用 购周边加赠Coding Plan Lite,Claude Code、Cursor等即刻畅享,学习进阶更高效! 阅读详情

 

阿里云服务器CentOS 5.7(64位)安装配置LAMP服务器(Apache+PHP5+MySQL)

 

 

 

一、快速安装Apache+PHP5+MySql

-----------------------------------------------------

补充:由于163的yum源上只有php5.1.6 mysql 5.0.95 版本较低,请直接看最后面的《八、卸载php5.1,mysql5.0 重新安装php5.4,mysql5.5》

 

安装163的yum源(参看我的别一篇文章)

 

ssh登录上服务器,先更新:

[root@AY1207241 /]# yum update

 

然后安装LAMP环境:(163的yum源上只有php5.1.6 mysql 5.0.95 版本较低)

[root@AY1207241 /]# yum -y install httpd php mysql mysql-server php-mysql httpd-manual mod_ssl mod_perl mod_auth_mysql php-mcrypt php-gd php-xml php-mbstring php-ldap php-pear php-xmlrpc mysql-connector-odbc mysql-devel libdbi-dbd-mysql

 

启动apache和mysql:

[root@AY1207241 /]# service httpd start   (重启是restart)

[root@AY1207241 /]# service mysqld start    (重启是restart)

 

设置为开机启动

chkconfig httpd on   #Apache设为开机启动

chkconfig mysqld on   #mysql设为开机启动

 

/etc/init.d/httpd start  #启动Apache

/etc/init.d/httpd restart  #重启Apache

 

---------

备注:Apache启动之后会提示错误:正在启动 httpd:httpd: Could not reliably determine the server's fully qualif domain name, using ::1 for ServerName      

解决办法:

vi /etc/httpd/conf/httpd.conf   #编辑

找到  #ServerName www.example.com:80

修改为 ServerName localhost:80

:wq!    #保存退出

 

Apache的配置文件:vi /etc/httpd/conf/httpd.conf

 

其中有:表示apache运行的用户

User apache
Group apache

 

二、测试PHP,输出php信息

-----------------------------------------------------

修改以下文件:

[root@AY1207241 /]# vi /var/www/html/index.php

输入测试PHP代码如下:

<?php  

phpinfo();

?> 

浏览器访问服务器IP地址,正常应该可以访问了。

 

三、Apache配置

-----------------------------------------------------

vi /etc/httpd/conf/httpd.conf 编辑文件

   Options Indexes FollowSymLinks        在331行 修改为:Options Includes ExecCGI FollowSymLinks(允许服务器执行CGI及SSI)

   #AddHandler cgi-script .cgi        在796行 修改为:AddHandler cgi-script .cgi .pl (允许扩展名为.pl的CGI脚本运行)

   AllowOverride None          在338行 修改为:AllowOverride All (允许.htaccess)

   AddDefaultCharset UTF-8         在759行 修改为:AddDefaultCharset GB2312 (添加GB2312为默认编码)

 Options Indexes MultiViews          找到这一行,将“Indexes”删除 ,变为此状态 Options MultiViews (不在浏览器上显示树状目录结构)

   DirectoryIndex index.html index.html.var          在 402行 修改为:DirectoryIndex index.html index.htm Default.html Default.htm index.php Default.php index.html.var  (设置默认首页文件,增加index.php)

   KeepAlive Off           在76行 修改为:KeepAlive On (允许程序性联机)

   MaxKeepAliveRequests 100          在83行 修改为:MaxKeepAliveRequests 1000 (增加同时连接数)  

:wq!  #保存退出

   /etc/init.d/httpd restart 重启

   DocumentRoot "/var/www/html"  修改为你的目录   "/data0/www/xxxxxxxxx"  (这个目录就是挂载的数据盘)

   rm -f /etc/httpd/conf.d/welcome.conf /var/www/error/noindex.html    #删除默认测试页

 

Apache的日志文件   
    ErrorLog  /etc/httpd/logs/error_log   (php的错误日志也输出到这里)
    CustomLog  /etc/httpd/logs/access_log combined

 

 

四、php配置

-----------------------------------------------------

vi  /etc/php.ini   #编辑

date.timezone = PRC     #在946行 把前面的分号去掉,改为date.timezone = PRC

magic_quotes_gpc = On   #在745行 打开magic_quotes_gpc来防止SQL注入  (php5.4开始不支持magic_quotes_gpc(防SQL流入))

log_errors = On         #记录错误日志

 

:wq!  #保存退出

/etc/init.d/httpd restart   #重启Apche , php

 

 

五、挂载数据盘

-----------------------------------------------------

阿里云服务器的硬盘由两块组成,一块是系统盘,一块是数据盘,默认数据盘是没有挂载的,如果要用到数据盘就需要自己手动挂载。

通过命令fdisk -l,可以看到设备名为/dev/xvdb。

另外在挂载前要对硬盘(/dev/xvdb)分区和格式化。

分区使用命令fdisk,格式化命令为mkfs.ext3。

如何操作可以参照官方文档【Linux 系统挂载数据盘 】http://help.aliyun.com/manual?helpId=271  

数据盘最多可以挂4块,挂在/data0,以后其它的可以挂在/data1,/data2,/data3

数据盘的作用,阿里云服务器控制台提供“重置”功能,可选重置系统盘,还是数据盘,如何操作系统坏了,你可以只重置系统盘,保留网站数据在数据盘。

 

六、配置MySql数据库--设置初始密码,建库,建表,导入数据

-----------------------------------------------------

请看这里:MySql备份与恢复,远程访问MySql服务器

 

 

七、把mysql的数据文件,移动到“数据盘”上,防止系统坏了重做系统时数据没有了。

-----------------------------------------------------

主要参考这篇文章:linux下MySQL安装配置及操作  

我再移mysql的数据文件后,使用mysql -u用户名 -p  登录时,遇到了错误 :ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

主要是修改my.cnf文件时有几步与上文不一样,这里说明一下。操作方法如下 :

1、停止mysql进程

 

2、把/var/lib/mysql整个目录移到/data0/db

mv /var/lib/mysql /home/data/

这样就把MySQL的数据文件移动到了/data0/db/mysql下

 

3、修改my.cnf配置文件

不要直接使用/etc/my.cnf配置文件,请到/usr/share/mysql/下找到*.cnf文件,拷贝其中一个(我是my-medium.cnf)到/etc/并改名为my.cnf)中。命令如下:

[root@test1 mysql]# cp /usr/share/mysql/my-medium.cnf /etc/my.cnf

 

4、编辑MySQL的配置文件/etc/my.cnf

为保证MySQL能够正常工作,需要指明mysql.sock文件的产生位置。

 

Java代码   收藏代码
  1. # The following options will be passed to all MySQL clients  
  2. [client]  
  3. #password   = your_password  
  4. port        = 3306  
  5. #socket     = /var/lib/mysql/mysql.sock  #注释了  
  6. socket=/data0/db/mysql/mysql.sock            #新加的内容  
  7. # Here follows entries for some specific programs  
  8.   
  9. # The MySQL server  
  10. [mysqld]  
  11. port        = 3306  
  12. #socket     = /var/lib/mysql/mysql.sock  #注释了  
  13. datadir=/data0/db/mysql                      #新加的内容  
  14. socket=/data0/db/mysql/mysql.sock            #新加的内容  

 

5、MySQL启动脚本/etc/rc.d/init.d/mysqld 不用做任何修改

我的版本是Server version: 5.0.95,其它版要不要改不知道 。

 

6、重新启动MySQL服务

/etc/rc.d/init.d/mysqld start

如果工作正常移动就成功了,否则对照前面的7步再检查一下。

 

 

移动完MySql之后,PHP连接不上Mysql数据库了

-----------------------------------------------------

经过上面的的操作,把MySql的数据文件移到其它目录后,PHP连接不上MySql数据库了,是因为找不mysql.sock文件。

报错信息如下:

 

Java代码   收藏代码
  1. Discuz! Database Error  
  2. (2002) notconnect  

解决方法一:

建一个软连接

cd /var/lib

mkdir mysql

ln -s  /data0/db/mysql/mysql.sock  /var/lib/mysql/mysql.sock

 

解决方案二:

修改/etc/php.ini文件

找到  mysql.default_socket =   一行,这个值一开始是空的,php将会使用内建在mysql中的默认值。

修改为以下内容:

mysql.default_socket = /data0/db/mysql/mysql.sock

mysql.sock的文件位置请跟据你的实际情况填写。

还有一处mysqli.default_socket =,要不要修改视情况吧,我没有修改。

 

-----------------------------------------------------

参考文章:

阿里云社区

linux下MySQL安装配置及操作  (修改密码,常用目录,修改数据文件位置)

CentOS 6.1安装配置LAMP服务器(Apache+PHP5+MySQL)

阿里云服务器搭建LAMP环境

云知识

 

 

 

 

八、卸载php5.1,mysql5.0 重新安装php5.4,mysql5.5

-----------CentOS 5.7 卸载php,mysql 重新安装php5.4,mysql5.5-----

前提,原来mysql是5.0,要保留数据,升级到5.5

查看php版本   php -v 

查看mysql版本  mysql -V

 

卸载mysql

rpm -qa |grep mysql  

rpm -e --nodeps  加上:每一个包名用空格隔开

 

卸载php

rpm -qa |grep php

rpm -e --nodeps  加上:每一个包名用空格隔开

提示: /etc/php.ini saved as /etc/php.ini.rpmsave

 

安装配置新的yum源

wget http://centos.ustc.edu.cn/epel/5/x86_64/epel-release-5-4.noarch.rpm

wget http://rpms.famillecollet.com/enterprise/5/remi/x86_64/remi-release-5-8.el5.remi.noarch.rpm

rpm -ivh *.rpm

 

查看可用的MySQL版本

# yum --enablerepo=remi list mysql mysql-server php

 

使用新yum源安装php5.4,mysql5.5

yum --enablerepo=remi -y install httpd php mysql mysql-server php-mysql httpd-manual mod_ssl mod_perl mod_auth_mysql php-mcrypt php-gd php-xml php-mbstring php-ldap php-pear php-xmlrpc mysql-connector-odbc mysql-devel libdbi-dbd-mysql

 

按以前安装的方法,再次修mysql , php 配置文件 

vi /etc/my.cnf     (主要是修改mysql的数据文件的路径 )

vi  /etc/php.ini    php5.4不支持magic_quotes_gpc(防SQL流入)

 

重启MySQL

# service mysqld start

 

升级MySQL

# mysql_upgrade -u root -p

 

-----------CentOS 5.7 MySQL 5.0.95如何升级成5.5---------------------

1.安装配置yum源

wget http://centos.ustc.edu.cn/epel/5/x86_64/epel-release-5-4.noarch.rpm

wget http://rpms.famillecollet.com/enterprise/5/remi/x86_64/remi-release-5-8.el5.remi.noarch.rpm

rpm -ivh *.rpm

 

查看可用的MySQL版本

# yum --enablerepo=remi list mysql mysql-server

 

更新或者安装MySQL(如果没有的话)

# yum --enablerepo=remi update mysql mysql-server

 

重启MySQL

# service mysqld start

 

升级MySQL

# mysql_upgrade -u root -p

 

---------CentOS 5.7 PHP5.1.6升级到5.3.23-------------------

rpm --import http://repo.webtatic.com/yum/RPM-GPG-KEY-webtatic-andy

wget -P /etc/yum.repos.d/ http://repo.webtatic.com/yum/webtatic.repo

yum --enablerepo=webtatic list php

发现有php5.2 和 php5.3可以升级。

我直接升级到5.3,执行:yum --enablerepo=webtatic  update -y php

如果想升级到5.2,执行:yum --enablerepo=webtatic --exclude=php*5.3* update -y php

参考:http://www.cnblogs.com/fangbo/archive/2010/04/16/1713600.html

高通平台camera构架sensor驱动详解 优先阅读。 阅读详情

相关推荐

Windows Server安装Intel I219-V网卡驱动完整教程

在Windows Server系统上安装Intel I219-V网卡驱动的方法。

小白成长历程 5028

阿里云Lamp服务器配置Apache

一、在lamp指定位置存放下载好的yii2框架(不用框架跳过此步) 假设指定将解压好的yii文件夹重命名为项目名称(fightfight.com),放到如图所示的位置。 要注意assets文件夹的读写权限打开。 二、按照镜像使用文档先给服务器配置一个虚拟主机 注意网站根目录选项,要直接定位到index.php的上层文件夹(如yii2框架,定位到web文件夹) 三、配置apache的h...

Punkkfish的博客 527

【Ultrascale+ MPSOC学习记录】10、PS端以太网使用lwip

还是参考ALINX教程,学习PS端以太网如何使用,从教程中可以看到,开发板使用了一个xilinx默认不支持的phy JL2121,所以需要修改lwip的库源码。

ryo891012的博客 814

centos7.2 lamp环境安装搭建mysql5.7.14+php7.0.9

centos7.2 lamp环境搭建 centos7.2 + apache2.4.23 + mysql5.7.14 + php7.0.9 + phpMyAdmin4.6.3 这是我在一台新购买的阿里云ECS centos7.2的服务器上搭建的lamp环境流程,只为搭建一个目前最新版的lamp测试环境,以下流程仅供参考。

追风的猪 1万+

购买阿里云服务器CentOs 6.8及搭建lamp环境

购买阿里云服务器CentOs 6.8及搭建lamp环境

18918615216的博客 2414

阿里云os自动安装mysql_阿里云服务器 centos yum安装LAMP环境 告别一键安装

之前的阿里云服务器环境都是用一键安装包的形式安装的。虽然安装的过程简单,但是安装之后就会出现磁盘占用太大。我做了一个简单的比较我用一键安装包的形式安装之后使用的空间是7G多,但是通过命令自行安装的话,使用的磁盘空间是2G多点。注:不是基于阿里云服务器安装mysql,php请参考下面的文章。好了,下面我们具体的看看,怎么用yum安装LNMP的环境。第一步:环境说明。linuxCentOS6.5n...

weixin_42195569的博客 289

阿里云ECS部署Lamp环境

阿里云ECS部署Lamp环境 系统平台:CentOS 7.2 Apache版本:2.4.23 Mysql 版本:5.7.17 Php版本:7.0.12 安装前准备CentOS 7.2系统默认开启了防火墙,需关闭后外部才可访问本机的80、21等端口,如需做安全类配置可自行参考官方文档关闭防火墙:systemctl stop firewalld.service关闭防火墙

学习-记录笔记-积累 2012

阿里云服务器CentOS 5.7(64位)安装配置LAMP服务器(Apache+PHP5+MySQL)

一、快速安装Apache+PHP5+MySql ----------------------------------------------------- 补充:由于163的yum源上只有php5.1.6 mysql 5.0.95 版本较低,请直接看最后面的《八、卸载php5.1,mysql5.0 重新安装php5.4,mysql5.5安装163的yum源(参看我的别一篇...

a3326112的博客 185

阿里云服务器CentOS(64位)安装配置LAMP服务器(Linux+Apache+PHP5+MySQL)

一 、使用 yum install httpd 命令安装apache //博主使用的是阿里云centos服务器,所以采用yum命令安装,ubuntu下的使用sudo apt-get install 安装成功后运行命令chkconfig –levels 235 httpd on使Apache可以自动启动,命令chkconfig –list 查看自动运行设置是否成功 。并运行命令/etc/i

西伯利亚小灰灰狼的博客 2162

阿里云服务器CentOS 5.7(64位)安装配置LAMP服务器(Apache+PHP5+MySQL

为什么80%的码农都做不了架构师?>>> ...

weixin_34160277的博客 125

php 5.4 mysql 5.7_Centos7.3_64位安装Apache2.4_mysql5.7_php5.4(阿里云LAMP php环境搭建图文教程)...

来源:https://blog.csdn.net/kesjc2017/article/details/76650845Centos7.3_64位安装Apache2.4_mysql5.7_php5.4(阿里云LAMP环境搭建图文教程)一、ApacheCentos7默认已经安装httpd服务,只是没有启动。如果你需要全新安装apache,可以yum install -y httpd启动服务:syste...

weixin_39666496的博客 208

阿里云ECS CentOs7.3下搭建LAMP环境(Apache2.4 + Mysql5.7 + PHP5.6 + Laravel5.2)

硬件是阿里云服务器ECS,安装阿里云提供的系统Linux CentOs7.3。LAMP环境搭建,再安装Laravel5.2框架。 硬件没什么好说的,不是很懂,买就是了。 至于系统为什么选择CentOs? 因为CentOs是公认的,个人服务器最合适的系统。 为什么选择7.3版本? 两个原则: 1、选公认的最稳定版本CentOs6.5,可惜阿里云默认的没有提...

weixin_34018169的博客 176

阿里云如何配置mysql数据库服务器配置_阿里云服务器安装配置mysql数据库

[ 阿里云服务器CentOS 5.7(64位)安装配置LAMP服务器(Apache+PHP5+MySQL) 一、快速安装Apache+PHP5+MySql -----------------------------------------------一、安装mysql数据库方法一、yum命令安装:yum install mysql方法二、下载安装文件:下载地址:htt...

weixin_34664632的博客 787

阿里云服务器 LAMP 手动搭建

手动搭建LAMP 过程 安装版本:apacheApache/2.4.6PHP: 7.2Mysql : 材料:阿里云服务器一台安全组放行80,22端口服务器版本CentOS 7.51.首先登录服务器执行:yum update -y2.安装Apache 服务 yum install httpd3.开启Apache 服务systemctl start httpd.service4.设置Apache ...

A丶微凉 587

centOS上搭建wordpress博客系统

购买VPS后,很多人都会选择自己搭建一个网站,其中使用LAMP+wordpress可以说是最简单的建站方案,下面我就将详细介绍一下具体的建站过程。我使用的是阿里云服务器,系统是centOS6.5,使用xshell 5 进行远程控制。 一、主要内容 1、安装LAMP服务器系统(Linux、ApacheMySQLPHP ); 2、安装wordpress; 二、具体步...

weixin_30270561的博客 345
上一篇: iPad与iPhone屏幕布局
下一篇: RDF 资源描述框架(Resource Description Framework)
kobi
博客等级 码龄17年 12粉丝 62原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值