Top.Mail.Ru
? ?
Journal created:
on 9 April 2004 (#2777408)
Updated:
on 21 March 2011
Location:
New Albany, Indiana, United States
Membership:
Open
Posting Access:
All Members , Moderated



"It's a great career - IF you make it. Anything less is terrible. It's a very unhealthy industry powered by intense greed and artistic sterility. Observe how moronically hard it is for anyone to get a project done. I've never seen anything so ridiculous. My advice is to avoid it unless you have a total compulsion to make movies and unless you're very lucky, you're in for a rough time of it." - Woody Allen


COMPLETE WORKS

RFC 001 - "BREADTIME"
An epic saga concerning the end of the world, the interview that could save it, and the fan determined to thwart such an eventuality. Featuring Amanda Coffey, Eric Condon, Ian Hoopes, Andrew Keeler, Kyle McCafferty, Daniel Robison, Pinko, Elvis and Fanny Pack. Nominally written and directed by Daniel Robison and Eric Condon, really more written and directed by Daniel, "realised" by all of RFC, edited by Kyle McCafferty, photographed by Eric, Daniel and Kyle. February 2003, Color, Hi-8 Video/studio cameras. 15 minutes.

RFC 002 - "FILTH AND DEGRADATION"
RFC's feature-length debut, this penetrating docudrama-style examination of infidelity and psychological warfare among a group of college-age emotional wrecks has won rave reviews from Indiana University Communication & Culture Professor Ted Striphas. Featuring Amanda Coffey, Kendall Epley, Kyle McCafferty, Daniel Robison, Blake Thomas and Anthony Bowman. Written, photographed and directed by Eric Condon, edited by Kyle McCafferty. August 2004, Color, mini-DV. 82 minutes.

RFC 003 - "THE WEDDING VIDEO"
This short vignette details the series of events triggered by the failure of a man's television to work in time to watch his friend's wedding video, and their disastrous aftermath. Featuring Eric Condon, Kyle McCafferty, and the formal RFC debut of Bryan Dominik as a GOOD citizen. Written, directed, photographed and edited by Daniel Robison. October 2004, Color, mini-DV. 6 minutes.

RFC 004 - "FEAR NOT A WOUNDED NAME"
This modest project, easily RFC's finest short-form work and possibly their best work period, details the unfortunate demise and ultimately tragic life of Boris Eastpak, and his time spent in purgatory awaiting his eternity. Featuring Daniel Robison, Bryan Dominik, Addison Koval, Travis Williams, and cameos by Eric Condon and Kyle McCafferty. Written, directed and edited by Daniel Robison, photographed by Daniel Robison with assistance from Bryan Dominik and Eric Condon. December 2004, Color, mini-DV. 16 minutes.

RFC 005 - "ASK AND ANSWER"
This work is among RFC's most obscure projects, featuring an unhinged Daniel Robison sounding off about anything and everything as his own camera tracks his movement through a forest and ultimately, into his own house, all the while discussing such issues as his various parkas, his homelessness, and his "Judaism." Featuring Daniel Robison and a cameo from Sarah Robison. Written, directed, photgraphed and edited by Daniel Robison, "in 40 minutes." December 2004, Color, digital still camera motion picture process. 16 minutes.

RFC 006 - "THE PASSPORT"
Eric's short-form filmmaking debut concerns the tale of Ms. Eleanor Thang, so determined to get to Austria-Hungary for her "big break" that she's willing to take a chance on the questionably-legitimate "Passports Made E-Z," run by none other than Pete Mesquite, a "Western treat" who always wanted to be a fashion photog. Featuring Bryan Dominik and Meghan Lamb. Written, directed, photographed and edited by Eric Condon, continuity by John Gahan. February 2005, Color, mini-DV. 6 minutes.

RFC 007 - "NEWS: EARS"
This documentary project details the sad tale of Peter Cash, so determined to be accepted despite his unusually small ears that he goes under the knife for a botched surgery that leaves him with freakish, elephantine aural appendages. Featuring who else but Russell Bryan. Written, directed, photographed and edited by Kyle McCafferty. February 2005, Color, DV-cam. 3 minutes.

RFC 008 - "I WANT TO ROT IN PUBLIC (DECOMPOSE)"
Kyle's brief music video for an excerpt of the Brisk's "I Want to Rot in Public (Decompose)" marks RFC's first stab at animation, as well as our first project ever to feature no live actors whatsoever. Featuring a potato, an orange, and various sundry items conspiring to create magic. Directed, animated, photographed and edited by Kyle McCafferty. March 2005, Color, mini-DV. 48 seconds.

RFC 009 - "TWO GUYS AND ONE BLUE BALL"
This oddly titled piece, easily RFC's most visually striking work, hinges on the interaction between one guy and the aforementioned blue ball, a stop-motion wonder that comes looking for drinking company and winds up wreaking havoc upon the WKU campus, culminating in a display of primal horror never before seen in Bowling Green. Featuring Matt Garrett and a blue ball. Written, directed and photographed by Matt Garrett and Kyle McCafferty, edited by Kyle McCafferty. May 2005, Color, DV-CAM. 4 minutes.

RFC 011 - "UNTITLED ANIMATION"
RFC's first completely animated project, this short piece depicts a stick figure's dramatic reaction to a menacing tornado and its even more menacing sound. Written, directed, edited and voiced by Kyle McCafferty. September 2005, B&W, animated. 11 seconds.

RFC 012 - "YOUNG LOVERS"
Eric's second short film shows the aftermath of a wild night that begat some hasty decisions, the fragility of our outward appearances and societal roles, and the ease with which a twist of fate can turn one's life very much upside down. Featuring Eric Condon, Coye Lloyd and Ana Ruge-Rodela. Written, directed and edited by Eric Condon, photographed by Coye Lloyd with additional photography by Eric and Ana. October 2005, Color, mini-DV. 13 minutes.

RFC 013 - "WE HATE KYLE"
Written, directed, edited, photographed by and starring Kyle McCafferty. December 2005, Color, mini-DV. 3 minutes.

RFC 014 - "12 AT 3"
Written by and starring Eric Condon. Directed, edited and photographed by Kyle McCafferty. March 2006, B&W, 16mm. 2 minutes.


CO-PRODUCTIONS

"AN ODYSSEY OF UNMISTAKEABLE [sic] PROPORTIONS" (2004)
Edited by Kyle McCafferty.

"UNTITLED MOTO-X VIDEO" (2005)
Edited by Kyle McCafferty.

"AMANDA COFFEY'S NEW ALBANY, INDIANA (POP. 37,603)" (2005)
Photographed and Edited by Eric Condon.


UNFILMED SCRIPTS

RFC 001.5 - "BREADTIME 2: I AM THE DOCTOR"
This epic resolves the issues raised in Breadtime, such as the fate of Pinko and Fanny Pack, how the boys are rewarded for their world-saving interview, and when, in fact, it finally will be Breadtime. Not revealed: the identity of who yelled "Gaaays." Featuring Anthony Bowman, Russell Bryan, Amanda Coffey, Eric Condon, Bryan Dominik, Ian Hoopes, Addison Koval, Kyle McCafferty, Andy Owen, Andrew Preston, Daniel Robison, Marge Robison, Sarah Robison, Stan Robison and Taffy Towel. Written and directed by Daniel Robison, edited by Kyle McCafferty, photographed by Eric, Bryan, Kyle and Daniel. Approximately 40 minutes.

RFC 002.5 - "CLASSICAL"
Daniel's quixotic masterpiece follows the travails of Carter Anderson, a small-time border patrolman with a unique plan to make money to support himself and his domineering girlfriend Edith, and the ensuing complications that turn this modest story into a blood tragedy. Featuring Anthony Bowman, Amanda Coffey, Eric Condon, Bryan Dominik, Kendall Epley, Ian Hoopes, Kyle McCafferty, Andrew Preston, Daniel Robison, and the Squirrel. Written and directed by Daniel Robison, photographed by Eric Condon, edited by Kyle McCafferty. Approximately 45 minutes.


UPCOMING PROJECTS

RFC 010 - "AS SOON AS YOU'RE BORN"
Featuring Eric Condon, Bryan Dominik, Kyle McCafferty, Daniel Robison, Beth Rosenbarger and Blake Thomas. Written and directed by Daniel Robison, edited by Kyle McCafferty, photographed by RFC. 120 minutes.


more to come.
12 at 3, 16mm, 8mm, a good citizen, adam the paperboy, addison koval, amanda coffey, andrew keeler, andrew preston, anita, annie, anscomatic, anthony bowman, apple g5, as-soon-as-you're-born, ask and answer, blake thomas, bob fossett jr., boris eastpak, boss greenpoint, breadtime, breadtime 2, bryan dominik, bunnie i loved you, carter anderson, charles chaplin, charlie kaufman, cinematography, classical, daniel robison, darlene roundtree, death wish, detective fillmore, directing, donna summer, dr. bradley logan, edith roundtree, editing, elvis, eric condon, fanny pack, fear-not-a-wounded-name, fidel flora, filmmaking, filth and degradation, final cut express, flaming chip records, framed picture of elvis, girl, greg, guerilla filmmaking, howard crest, i am the doctor, ian hoopes, independent filmmaking, jed, jerry turner, joe trillionaire, john cassavetes, john deere, joseph sinclair, julian, kendall epley, kyle mccafferty, location shooting, louis, lucy, lyle the pizza guy, marlon brando, matt garrett, meghan lamb, mexican man/mexican woman, michael jackson, mini dv, miss eleanor thang, molly, mp3, mrs. mcguirk, muffy lucas, neil, news: ears, nick and abe, nick robinson, not having a permit, paperboy, pat mad dog money, paul deines, peabody awards, person, pete mesquite, peter, peter cash, pierre la mappe, pinko, plastic for president, policeman scuzz, producing, rabbit film company, richard karn, rick forest, rick moranis, russell bryan, salem, sammy bagels, samsung, sarah robison, screenwriting, sony handicam, sony vaio, spare tire entertainment, stan robison, stop-motion animation, taffy towel, talkie, tcb, ted, thatnightaterics.com, the brisk, the mailman, the park, the passport, the revelator, the wedding video, the world, two-guys-and-one-blue-ball, visions of cody, voc, waffle & steak, we hate kyle, wendy, what if, windows 95, winston churchballs, wnas, woody allen, www.shut-up.com, young lovers

Statistics